aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-10 23:31:47 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-10 23:31:47 -0400
commitef807e48d411e598c1b5e043d3ca5f3d9a1778dc (patch)
tree94e92589ccfe5370a8c2d7fa535f1aee06e2cf07 /gnu/packages/networking.scm
parent756e1483c8578d91ec7dde35257ad88148b0c6cc (diff)
downloadguix-ef807e48d411e598c1b5e043d3ca5f3d9a1778dc.tar.gz
guix-ef807e48d411e598c1b5e043d3ca5f3d9a1778dc.zip
gnu: restinio: Update to 0.6.18-0.eda471e and enable tests.
* gnu/packages/networking.scm (restinio): Update to 0.6.18-0.eda471e. [version]: Use git-version. [arguments]: Enable tests, removing #:tests? argument.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm95
1 files changed, 48 insertions, 47 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index e7ad1c5599..1ba6c5300d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3709,55 +3709,56 @@ communication over HTTP.")
(license license:agpl3+)))
(define-public restinio
- (package
- (name "restinio")
- (version "0.6.17")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Stiffstream/restinio")
- (commit (string-append "v." version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1jpvfa2sjkihbkcc1q6c9zb1vry9mkkhbz2jrl831bqslpq9la3p"))))
- (build-system cmake-build-system)
- (arguments
- (list
- ;; Multiple tests fail to run in the build container due to host name
- ;; resolution (see: https://github.com/Stiffstream/restinio/issues/172).
- #:tests? #f
- #:configure-flags #~(list "-DRESTINIO_FIND_DEPS=ON"
- "-DRESTINIO_INSTALL=ON"
- "-DRESTINIO_TEST=ON"
- "-DRESTINIO_USE_EXTERNAL_HTTP_PARSER=ON"
- "-DRESTINIO_USE_EXTERNAL_SOBJECTIZER=ON")
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'change-directory
- (lambda _
- (chdir "dev"))))))
- (native-inputs
- (list catch2
- clara
- json-dto))
- (inputs
- (list openssl
- sobjectizer))
- (propagated-inputs
- ;; These are all #include'd by restinio's .hpp header files.
- (list asio
- fmt
- http-parser
- pcre
- pcre2
- zlib))
- (home-page "https://stiffstream.com/en/products/restinio.html")
- (synopsis "C++14 library that gives you an embedded HTTP/Websocket server")
- (description "RESTinio is a header-only C++14 library that gives you an embedded
+ ;; Temporarily use an unreleased commit, which includes fixes to be able to
+ ;; run the test suite in the resolver-less Guix build environment.
+ (let ((revision "0")
+ (commit "eda471ec3a2815965ca02ec93a1124a342b7601d"))
+ (package
+ (name "restinio")
+ (version (git-version "0.6.18" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Stiffstream/restinio")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0f4w7714r0ic7csgxydw2vzfh35ssk34pns9jycmc08dzc3r7whb"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list "-DRESTINIO_FIND_DEPS=ON"
+ "-DRESTINIO_INSTALL=ON"
+ "-DRESTINIO_TEST=ON"
+ "-DRESTINIO_USE_EXTERNAL_HTTP_PARSER=ON"
+ "-DRESTINIO_USE_EXTERNAL_SOBJECTIZER=ON")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "dev"))))))
+ (native-inputs
+ (list catch2
+ clara
+ json-dto))
+ (inputs
+ (list openssl
+ sobjectizer))
+ (propagated-inputs
+ ;; These are all #include'd by restinio's .hpp header files.
+ (list asio
+ fmt
+ http-parser
+ pcre
+ pcre2
+ zlib))
+ (home-page "https://stiffstream.com/en/products/restinio.html")
+ (synopsis "C++14 library that gives you an embedded HTTP/Websocket server")
+ (description "RESTinio is a header-only C++14 library that gives you an embedded
HTTP/Websocket server. It is based on standalone version of ASIO
and targeted primarily for asynchronous processing of HTTP-requests.")
- (license license:bsd-3)))
+ (license license:bsd-3))))
(define-public opendht
(package