aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-08 21:56:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-08 21:58:53 +0200
commite7d61dfe57290442c0af193e9e16a1eeb668f0f8 (patch)
tree33f0267383a3a9d02347f7447fddcecc4d388b38 /gnu/packages/networking.scm
parentae9fb02bb5364dce2a7995253216d28485c19e64 (diff)
downloadguix-e7d61dfe57290442c0af193e9e16a1eeb668f0f8.tar.gz
guix-e7d61dfe57290442c0af193e9e16a1eeb668f0f8.zip
gnu: nanomsg: Don't build html documentation.
* gnu/packages/networking.scm (nanomsg)[outputs]: Remove 'doc' output. [arguments]: Remove phase moving html to doc output. [native-inputs]: Remove ruby-asciidoctor, pkg-config. Change-Id: Ie44d250572e652f14981f0d0edfa2de7ae5e62c0
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm19
1 files changed, 1 insertions, 18 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b0381515a5..1a8912ac87 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -154,7 +154,6 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
- #:use-module (gnu packages ruby)
#:use-module (gnu packages samba)
#:use-module (gnu packages serialization)
#:use-module (gnu packages shells)
@@ -867,25 +866,9 @@ publish/subscribe, RPC-style request/reply, or service discovery.")
(sha256
(base32 "01ddfzjlkf2dgijrmm3j3j8irccsnbgfvjcnwslsfaxnrmrq5s64"))))
(build-system cmake-build-system)
- (outputs '("out" "doc"))
(arguments
`(#:configure-flags
- (list
- "-DNN_ENABLE_COVERAGE=ON")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'move-docs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc")))
- (mkdir-p (string-append doc "/share/doc"))
- (rename-file
- (string-append out "/share/doc/nanomsg")
- (string-append doc "/share/doc/nanomsg"))
- #t))))))
- (native-inputs
- `(("asciidoctor" ,ruby-asciidoctor)
- ("pkg-config" ,pkg-config)))
+ (list "-DNN_ENABLE_COVERAGE=ON")))
(synopsis "Scalable socket library")
(description "Nanomsg is a socket library that provides several common
communication patterns. It aims to make the networking layer fast, scalable,