aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-03-17 22:03:57 +0000
committerLudovic Courtès <ludo@gnu.org>2023-03-26 23:28:02 +0200
commitc06b6ce2572410eb6b904d5ade219b5023143517 (patch)
tree59c71aede7e7de6d978b6c66587305806d8760fc /gnu/packages/networking.scm
parentfa715278bcb62874580d4b72ad3b0545e8a686e5 (diff)
downloadguix-c06b6ce2572410eb6b904d5ade219b5023143517.tar.gz
guix-c06b6ce2572410eb6b904d5ade219b5023143517.zip
gnu: haproxy: Move to (gnu packages high-availability).
Copyright records were synchronized based on commit history. * gnu/packages/networking.scm (haproxy): Move this variable from here... * gnu/packages/high-availability.scm (haproxy): ...to here. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm48
1 files changed, 1 insertions, 47 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 7d4a928ad7..ae26105c2c 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -30,7 +30,7 @@
;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
-;;; Copyright © 2019, 2020, 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2019, 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; Copyright © 2019 Daniel Schaefer <git@danielschaefer.me>
@@ -4236,52 +4236,6 @@ cables.")
"file://COPYING.slirpvde"
"See COPYING.slirpvde in the distribution."))))))
-(define-public haproxy
- (package
- (name "haproxy")
- (version "2.7.5")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.haproxy.org/download/"
- (version-major+minor version)
- "/src/haproxy-" version ".tar.gz"))
- (sha256
- (base32 "00j5lwvrf8lgfid3108gclxbd46v3mnd4lh0lw4l0nn3f0rf9ip2"))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:tests? #f ; there are only regression tests, using varnishtest
- #:make-flags
- #~(list "LUA_LIB_NAME=lua"
- "TARGET=linux-glibc"
- "USE_LUA=1"
- "USE_OPENSSL=1"
- "USE_PCRE2=1"
- "USE_PCRE2_JIT=1"
- "USE_PROMEX=1"
- "USE_ZLIB=1"
- (string-append "CC=" #$(cc-for-target))
- (string-append "DOCDIR=" #$output "/share/" #$name)
- (string-append "LUA_INC=" #$(this-package-input "lua") "/include")
- (string-append "LUA_LIB=" #$(this-package-input "lua") "/lib")
- (string-append "PREFIX=" #$output))
- #:phases
- #~(modify-phases %standard-phases
- (delete 'configure))))
- (inputs
- (list lua openssl pcre2 zlib))
- (home-page "https://www.haproxy.org/")
- (synopsis "Reliable, high performance TCP/HTTP load balancer")
- (description "HAProxy offers @acronym{HA, high availability}, load
-balancing, and proxying for TCP and HTTP-based applications. It is particularly
-suited to Web sites crawling under very high loads while needing persistence or
-Layer 7 processing. Supporting tens of thousands of connections is clearly
-realistic with today's hardware.")
- (license (list license:gpl2+
- license:lgpl2.1
- license:lgpl2.1+))))
-
(define-public lldpd
(package
(name "lldpd")