aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authormason1920 <mason1920@use.startmail.com>2023-11-10 14:47:50 -0500
committerJelle Licht <jlicht@fsfe.org>2023-11-12 16:43:48 +0100
commit978f4a9dc4c09d12383561d7ae7ab3441c744ebd (patch)
tree07458fc2eb037ec36bfa560885a90d05b181cd64 /gnu/packages/networking.scm
parent1a775399879fcc7c06444f9117630329f1cb6365 (diff)
downloadguix-978f4a9dc4c09d12383561d7ae7ab3441c744ebd.tar.gz
guix-978f4a9dc4c09d12383561d7ae7ab3441c744ebd.zip
gnu: Add ngtcp2.
* gnu/packages/networking.scm (ngtcp2): New variable. Change-Id: Id8fcedf0f2843fa37983cecb98fb76a5ccdcdc22 Signed-off-by: Jelle Licht <jlicht@fsfe.org>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1a8912ac87..2028830087 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4398,6 +4398,27 @@ client and server. It allows you to use remote block devices over a TCP/IP
network.")
(license license:gpl2)))
+(define-public ngtcp2
+ (package
+ (name "ngtcp2")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ngtcp2/ngtcp2/"
+ "releases/download/v" version "/"
+ "ngtcp2-" version ".tar.xz"))
+ (sha256
+ (base32 "0l84hnj9n4bfxjizgmqsqbz71jx7m00a7l1z43fg5ls3apx9ij11"))))
+ (build-system gnu-build-system)
+ (native-inputs (list cunit))
+ (home-page "https://nghttp2.org/ngtcp2/")
+ (synopsis "QUIC protocol implementation")
+ (description
+ "The ngtcp2 project is an effort to implement the RFC9000 (IETF)
+QUIC protocol.")
+ (license license:expat)))
+
(define-public yggdrasil
(package
(name "yggdrasil")