aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-10-28 11:55:24 +0800
committerHilton Chain <hako@ultrarare.space>2024-01-13 17:07:17 +0800
commit551d013a56bf7d22bac80e0fd21d971973c3cf6f (patch)
tree3dce27827d61f22a3ad58674bf73057bd0d1a4ce /gnu/packages/networking.scm
parent17a942d64338330776855360fa8b73819d2b2ee3 (diff)
downloadguix-551d013a56bf7d22bac80e0fd21d971973c3cf6f.tar.gz
guix-551d013a56bf7d22bac80e0fd21d971973c3cf6f.zip
gnu: iwd: Patch resolvconf path.
* gnu/packages/networking.scm (iwd)[inputs]: Add openresolv. [arguments]<#:phases>: Add 'patch-resolvconf-path. Change-Id: Ica59a76dd6318e06979314e4b49c5371f4c98e4d
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a064053d8a..2f62194c56 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -113,6 +113,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages dejagnu)
+ #:use-module (gnu packages dns)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
@@ -4066,7 +4067,7 @@ powerful route filtering syntax and an easy-to-use configuration interface.")
"199pcs20054xhp5c0dnxf9ny5cf5cynkqpx68dpn46nq8ly76n2y"))))
(build-system gnu-build-system)
(inputs
- (list dbus ell (package-source ell) readline))
+ (list dbus ell (package-source ell) openresolv readline))
(native-inputs
(list autoconf
automake
@@ -4102,6 +4103,13 @@ powerful route filtering syntax and an easy-to-use configuration interface.")
(copy-file (string-append ell-header-dir "/" file-name)
(string-append target-dir "/" file-name)))
'("asn1-private.h" "useful.h")))))
+ (add-after 'unpack 'patch-resolvconf-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/resolve.c"
+ (("getenv\\(\"PATH\"\\)")
+ (format #f "\"~a\""
+ (dirname (search-input-file
+ inputs "sbin/resolvconf")))))))
(add-after 'configure 'patch-Makefile
(lambda _
(substitute* "Makefile"