;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2020 Ryan Prior ;;; Copyright © 2023 Wamm K. D. ;;; Copyright © 2023, 2024 altadil ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages pantheon) #:use-module (gnu packages cmake) #:use-module (gnu packages freedesktop) #:use-module (gnu packages gettext) #:use-modu
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:34 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:12 +0200
commit157cdce9c34c99250e86f294cdf8b47e080f60d5 (patch)
treea79e3fcb9f3786c5caf13f7b1b9c456b2606048f /gnu/packages/networking.scm
parent4c9d88a18bc6ea29856e26e24cadef3b424948c0 (diff)
downloadguix-157cdce9c34c99250e86f294cdf8b47e080f60d5.tar.gz
guix-157cdce9c34c99250e86f294cdf8b47e080f60d5.zip
gnu: iputils: Restyle description and native-inputs.
* gnu/packages/networking.scm (iputils)[native-inputs]: Reorder inputs. [description]: Use @table over @itemize. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm40
1 files changed, 24 insertions, 16 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b07a0e170e..b43c281b15 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1653,28 +1653,36 @@ intended as a substitute for the PPPStatus and EthStatus projects.")
(("if build_ping == true")
"if false")))))))
(native-inputs
- (list gettext-minimal
- pkg-config
- docbook-xsl
- docbook-xml-5.0.1
- libxml2 ;for XML_CATALOG_FILES
- libxslt))
+ (list docbook-xsl docbook-xml-5.0.1
+ gettext-minimal
+ libxml2 ;for XML_CATALOG_FILES
+ libxslt pkg-config))
(inputs
(list libcap libidn2 openssl))
(synopsis "Collection of network utilities")
(description
"This package contains a variety of tools for dealing with network
configuration, troubleshooting, or servers. Utilities included are:
-
-@itemize @bullet
-@item @command{arping}: Ping hosts using the @dfn{Address Resolution Protocol}.
-@item @command{clockdiff}: Compute time difference between network hosts
-using ICMP TSTAMP messages.
-@item @command{ping}: Use ICMP ECHO messages to measure round-trip delays
-and packet loss across network paths.
-@item @command{tracepath}: Trace network path to an IPv4 or IPv6 address and
-discover MTU along the way.
-@end itemize")
+@table @command
+@item arping
+Ping hosts using @acronym{ARP, Address Resolution Protocol}.
+@item clockdiff
+Compute time difference between network hosts using ICMP TSTAMP messages.
+@item ninfod
+Daemon that responds to IPv6 Node Information Queries.
+@item ping
+Use ICMP ECHO messages to measure round-trip delays and packet loss across
+network paths.
+@item rarpd
+Answer RARP requests from clients.
+@item rdisc
+Populate network routing tables with information from the ICMP router
+discovery protocol.
+@item tftpd
+Trivial file transfer protocol server.
+@item tracepath
+Trace network path to an IPv4 or IPv6 address and discover MTU along the way.
+@end table")
;; The various utilities are covered by different licenses, see LICENSE
;; for details.
(license (list license:gpl2+ ;arping, tracepath
deload needs these in the environment to fetch data securely from ;; Flatpak remotes. (list gnupg gpgme)) (native-inputs `(("gettext" ,gettext-minimal) ("glib:bin" ,glib "bin") ("gobject-introspection" ,gobject-introspection) ("pkg-config" ,pkg-config) ("vala" ,vala))) (home-page "https://github.com/elementary/sideload") (synopsis "Graphical application to side-load Flatpaks") (description "Sideload handles flatpakref files, like those you might find on Flathub or another third-party website providing a Flatpak app for download.") (license license:gpl3+))) (define-public pantheon-wallpapers (package (name "pantheon-wallpapers") (version "7.0.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/elementary/wallpapers/") (commit version))) (file-name (git-file-name name version)) (sha256 (base32 "0km3h52kapbm8ymwxdxasz80qbgzkfni7981pdyf740wjp7linwb")))) (build-system meson-build-system) (native-inputs (list gettext-minimal)) ; for msgfmt (inputs (list libexif)) (synopsis "Wallpapers for the Pantheon desktop") (description "This package provides wallpapers for the Pantheon desktop.") (home-page "https://github.com/elementary/wallpapers") (license (list license:cc-by-sa4.0 license:cc0 (license:non-copyleft "https://unsplash.com/license") (license:non-copyleft "https://www.pexels.com/license/")))))