aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-02 19:55:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-02 23:08:10 +0200
commit08a8b340443904931275ef0aa13a23fd653ccd06 (patch)
tree093062a58a2ddbf5e4a41604a7a84f5f49df7859 /gnu/packages/networking.scm
parent433b391f9e4d7aaff3e808721b670828759cbb1a (diff)
downloadguix-08a8b340443904931275ef0aa13a23fd653ccd06.tar.gz
guix-08a8b340443904931275ef0aa13a23fd653ccd06.zip
gnu: zeromq: Update to 4.3.3.
* gnu/packages/networking.scm (zeromq): Update to 4.3.3.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 63541629f3..f7093e1b35 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -840,18 +840,17 @@ transparently check connection attempts against an access control list.")
(license (license:non-copyleft "file://DISCLAIMER"
"See the file DISCLAIMER in the distribution."))))
-
(define-public zeromq
(package
(name "zeromq")
- (version "4.3.2")
+ (version "4.3.3")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/zeromq/libzmq/releases"
"/download/v" version "/zeromq-" version ".tar.gz"))
(sha256
(base32
- "0qzp80ky4y2k7k1ya09v9gkivvfbz2km813snrb8jhnn634bbmzb"))))
+ "18km71p77jm1w7wly2a5mxvphjb0f2l6s08cg382x55f6zdqb4lx"))))
(build-system gnu-build-system)
(home-page "https://zeromq.org")
(synopsis "Library for message-based applications")
ust-serde-1, rust-zerioze-1. Replace rust-constant-time-eq-0.1 with 0.3, rust-digest-0.9 with 0.10. Remove rust-crypto-mac-0.11. [cargo-development-inputs]: Add rust-serde-json-1, rust-tempfile-3. Replace rust-page-size-0.4 with 0.6. Remove rust-cc-1. 2023-10-18gnu: rust-minisign: Update to 0.7.5.Efraim Flashner * gnu/packages/crates-io.scm (rust-minisign): Update to 0.7.5. [cargo-inputs]: Replace rust-getrandom-0.1 with 0.2, rust-rpassword-4 with 7, rust-scrypt-0.3 with 0.11. 2023-10-17gnu: crypto++: Add tunable property.Jean-Pierre De Jesus DIAZ * gnu/packages/crypto.scm (crypto++): Set tunable? property to true. Signed-off-by: Christopher Baines <mail@cbaines.net> 2023-10-17gnu: crypto++: Update to 8.8.0.Jean-Pierre De Jesus DIAZ * gnu/packages/crypto.scm (crypto++): Update to 8.8.0. [arguments]: Update to new style. Remove .so symbolic link installation as the project does it now. Fix cross-compilation for GNU/Linux and MinGW targets. Signed-off-by: Christopher Baines <mail@cbaines.net>