aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/myrddin.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-25 23:36:11 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-25 23:48:37 -0500
commit0d41fe4855588fb659b8adafe215d5573517a79b (patch)
tree38b274bd03375f4fa5b7d3a9fb3f64a19786bef2 /gnu/packages/myrddin.scm
parent7c57821c68d199ad56a8ed750b36eccc7ef238dd (diff)
parent1a5302435ff0d2822b823f5a6fe01faa7a85c629 (diff)
downloadguix-0d41fe4855588fb659b8adafe215d5573517a79b.tar.gz
guix-0d41fe4855588fb659b8adafe215d5573517a79b.zip
Merge branch 'staging' into core-updates.
With "conflicts" resolved in (mostly in favor of master/staging): gnu/packages/admin.scm gnu/packages/gnuzilla.scm gnu/packages/gtk.scm gnu/packages/kerberos.scm gnu/packages/linux.scm guix/lint.scm
Diffstat (limited to 'gnu/packages/myrddin.scm')
-rw-r--r--gnu/packages/myrddin.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/myrddin.scm b/gnu/packages/myrddin.scm
new file mode 100644
index 0000000000..897276f57d
--- /dev/null
+++ b/gnu/packages/myrddin.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Guix Together <jgart@dismail.de>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages myrddin)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix utils)
+ #:use-module (guix download)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages pkg-config)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public myrddin
+ (package
+ (name "myrddin")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/oridb/mc")
+ (commit (string-append "r" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0acqqz74ypmjvi1yqz7g1ymyk3mmkzwqgmdd3s7s287bdy4a72gc"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'build
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "bootstrap" make-flags)
+ (apply invoke "make" make-flags))))))
+ (native-inputs
+ (list bison pkg-config))
+ (home-page "https://myrlang.org")
+ (synopsis "Compiler and tools for the Myrddin programming language")
+ (description
+ "Myrddin is a programming language. It features strong type checking,
+generics, type inference, closures, and traits. It aims for C like low level
+control. This combination makes Myrddin suitable for anything ranging from
+desktop applications, to embedded systems and potentially even kernel
+development.")
+ (license license:expat)))