aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:41 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:52 +0000
commitd130524d70fa5485bb697671a8e9db11650f6cfc (patch)
treef0e8a6e219c9c2031264186392711cd28ada68ed /gnu/packages/music.scm
parentb764e1c9492ca6760a90c130b85554f4b331a655 (diff)
downloadguix-d130524d70fa5485bb697671a8e9db11650f6cfc.tar.gz
guix-d130524d70fa5485bb697671a8e9db11650f6cfc.zip
gnu: abjad: Update to 3.19.
* gnu/packages/music.scm (abjad): Update to 3.19. [arguments]: Remove uneeded field. [native-inputs]: Remove all native-inputs except python-pytest. Change-Id: Iad5b855734650d15dd0a2a8db6312e8d9a3de24a Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm31
1 files changed, 3 insertions, 28 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 33ac2e8a6f..027a0d7ec9 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1797,8 +1797,7 @@ listeners answer questions about music quickly and simply.")
(define-public abjad
(package
(name "abjad")
- ;; XXX: The latest version which supports current Guix's Python 3.9.9.
- (version "3.4")
+ (version "3.19")
(source
(origin
(method git-fetch)
@@ -1807,36 +1806,12 @@ listeners answer questions about music quickly and simply.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0s63vk9fifp0im9c31kb9ck39mbaxhrls993d8fvg0nkg41z1jnz"))))
+ (base32 "1cgcnmwzxx2hr21pqm1hbsknpad748yw3gf7jncsb3w1azhjypzm"))))
(build-system pyproject-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- ;; XXX. Permit newer version of uqbar, remove for >3.4. Remove in
- ;; the next update.
- (add-after 'unpack 'loosen-requirements
- (lambda _
- (substitute* "setup.py"
- ((", <0\\.5\\.0") ""))))
- ;; FIXME: Check why it's failing with this: Note: compilation failed
- ;; and \version outdated, did you update input syntax with
- ;; convert-ly?
- (add-before 'check 'disable-failing-tests
- (lambda _
- (substitute* "tests/test_ext_sphinx.py"
- (("def test_ext_sphinx_01") "def __off_test_ext_sphinx_01")))))))
(inputs
(list lilypond))
(native-inputs
- (list python-flake8
- python-isort
- python-mypy
- python-pytest
- python-pytest-cov
- python-pytest-helpers-namespace
- python-six
- python-sphinx-autodoc-typehints))
+ (list python-pytest))
(propagated-inputs
(list python-quicktions
python-ply