aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-02-02 00:13:08 +0100
committerAndreas Enge <andreas@enge.fr>2013-02-04 11:12:32 +0100
commit8cc9c0daddd245f8dfa75d8ae33e79d6ae6fbf28 (patch)
tree50307447257eab5f0350875cf880ba14f873d71d /gnu/packages/mp3.scm
parentd464e72566ca3fe4cec9786921501e271054fd45 (diff)
downloadguix-8cc9c0daddd245f8dfa75d8ae33e79d6ae6fbf28.tar.gz
guix-8cc9c0daddd245f8dfa75d8ae33e79d6ae6fbf28.zip
gnu: Add libid3tag.
* gnu/packages/mp3 (libid3tag): New variable.
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index c5a13aa7c6..7eb34a615f 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -20,6 +20,7 @@
#:use-module ((guix licenses)
#:renamer (symbol-prefix-proc 'license:))
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages oggvorbis)
#:use-module (guix packages)
#:use-module (guix download)
@@ -59,3 +60,24 @@ This package contains the library.")
(license license:gpl2+)
(home-page "http://www.underbit.com/products/mad/")))
+(define-public libid3tag
+ (package
+ (name "libid3tag")
+ (version "0.15.1b")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/mad/libid3tag/"
+ version "/libid3tag-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0lb1w883dc46dajbdvnia5870brl5lvnlk7g7y58y9wpg5p4znk3"))))
+ (build-system gnu-build-system)
+ (inputs `(("zlib" ,zlib)))
+ (synopsis "libid3tag, a library for reading ID3 tags")
+ (description
+ "libid3tag is a library for reading ID3 tags, both ID3v1 and the various
+versions of ID3v2")
+ (license license:gpl2+)
+ (home-page "http://www.underbit.com/products/mad/")))
+