aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-11-15 00:19:16 +0530
committerArun Isaac <arunisaac@systemreboot.net>2022-11-15 00:19:16 +0530
commitd0118c9930f1f4fac7c9f75c3894b141566561ec (patch)
treee9499973e15b33c915eb06ee29aabdb8b683a15d /gnu/packages/messaging.scm
parent0581f1118130d96d522fae78d230457a32755956 (diff)
downloadguix-d0118c9930f1f4fac7c9f75c3894b141566561ec.tar.gz
guix-d0118c9930f1f4fac7c9f75c3894b141566561ec.zip
gnu: prosody: Invoke prosody wrapper script directly.
* gnu/packages/messaging.scm (prosody)[arguments]: Add invoke-prosody-wrapper phase.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index db1c96f9dc..9927c7c323 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1538,6 +1538,15 @@ Qt-based XMPP library QXmpp.")
(("^INSTALLEDCONFIG =.*") "INSTALLEDCONFIG = /etc/prosody\n")
;; prosodyctl needs a place to put auto-generated certificates.
(("^INSTALLEDDATA =.*") "INSTALLEDDATA = /var/lib/prosody\n"))))
+ (add-after 'unpack 'invoke-prosody-wrapper
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Invoke the prosody wrapper script instead of invoking lua on
+ ;; the actual executable.
+ (substitute* "util/prosodyctl.lua"
+ (("os.execute\\(lua[^;]*")
+ (string-append "os.execute(\""
+ (assoc-ref outputs "out")
+ "/bin/prosody -D\")")))))
(add-after 'install 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make sure all executables in "bin" find the required Lua