aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-03-06 00:07:07 -0500
committerMark H Weaver <mhw@netris.org>2014-03-06 10:23:45 -0500
commit8b3099cf03b2d1ebcd233b4a35d132cd73b5728d (patch)
treeb7b0936db24f4d7399948f716ffa053ba7259600 /gnu/packages/messaging.scm
parent7c706558f564e878415a14d32286c31c5ef370fb (diff)
downloadguix-8b3099cf03b2d1ebcd233b4a35d132cd73b5728d.tar.gz
guix-8b3099cf03b2d1ebcd233b4a35d132cd73b5728d.zip
gnu: Add bitlbee.
* gnu/packages/messaging.scm (bitlbee): New variable. * gnu/packages/patches/bitlbee-fix-tests.patch: New file. * gnu/packages/patches/bitlbee-memset-fix.patch: New file. * gnu-system.am (dist_patch_DATA): Add patches.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm59
1 files changed, 57 insertions, 2 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 34efa85970..c1a755ef84 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -17,11 +17,20 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages messaging)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses)
+ #:select (gpl2+ gpl2 lgpl2.1 bsd-2))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module (gnu packages gnupg))
+ #:use-module (gnu packages)
+ #:use-module (gnu packages gnupg)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnutls)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages check))
(define-public libotr
(package
@@ -65,4 +74,50 @@ providing:
(sha256
(base32 "1x6dd4rh499hdraiqfhz81igrj0a5rs0gjhc8l4sljwqhjjyla6l"))))))
+(define-public bitlbee
+ (package
+ (name "bitlbee")
+ (version "3.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://get.bitlbee.org/src/bitlbee-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0n8g5452i5qap43zxb83gxp01d48psf6rr3k1q7z6a3dgpfi3x00"))
+ (patches (list (search-patch "bitlbee-memset-fix.patch")
+ (search-patch "bitlbee-fix-tests.patch")))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("check" ,check)))
+ (inputs `(("glib" ,glib)
+ ("libotr" ,libotr-3)
+ ("gnutls" ,gnutls)
+ ("zlib" ,zlib) ; Needed to satisfy "pkg-config --exists gnutls"
+ ("python" ,python-2)
+ ("perl" ,perl)))
+ (arguments
+ `(#:phases (alist-cons-after
+ 'install 'install-etc
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ (zero? (apply system* "make" "install-etc" make-flags)))
+ (alist-replace
+ 'configure
+ ;; bitlbee's configure script does not tolerate many of the
+ ;; variable settings that Guix would pass to it.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system* "./configure"
+ (string-append "--prefix="
+ (assoc-ref outputs "out"))
+ "--otr=1")))
+ %standard-phases))))
+ (synopsis "IRC to instant messaging gateway")
+ (description "BitlBee brings IM (instant messaging) to IRC clients, for
+people who have an IRC client running all the time and don't want to run an
+additional IM client. BitlBee currently supports XMPP/Jabber (including
+Google Talk), MSN Messenger, Yahoo! Messenger, AIM and ICQ, and the Twitter
+microblogging network (plus all other Twitter API compatible services like
+identi.ca and status.net).")
+ (home-page "http://www.bitlbee.org/")
+ (license (list gpl2+ bsd-2))))
+
;;; messaging.scm ends here