aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-09 11:07:13 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-10 23:38:55 +0100
commite1605e36a804d5d67fd926ea529d9bab38bc87b7 (patch)
treed944bc3c9053091bed8b154144ab2d23a89e9f03 /gnu/packages/maths.scm
parentc58ed7732ac31ba3829e1bbb4342b63c84e6d44b (diff)
downloadguix-e1605e36a804d5d67fd926ea529d9bab38bc87b7.tar.gz
guix-e1605e36a804d5d67fd926ea529d9bab38bc87b7.zip
gnu: Add openlibm.
* gnu/packages/maths.scm (openlibm): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 231206ce30..24c4149587 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -991,6 +991,43 @@ based on transforming an expression into a bytecode and precalculating
constant parts of it.")
(license license:expat)))
+(define-public openlibm
+ (package
+ (name "openlibm")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/JuliaLang/openlibm/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0cwqqqlblj3kzp9aq1wnpfs1fl0qd1wp1xzm5shb09w06i4rh9nn"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:phases
+ ;; no configure script
+ (alist-delete 'configure %standard-phases)
+ #:tests? #f)) ;the tests are part of the default target
+ (home-page "http://openlibm.org/")
+ (synopsis "Portable C mathematical library (libm)")
+ (description
+ "OpenLibm is an effort to have a high quality, portable, standalone C
+mathematical library (libm). It can be used standalone in applications and
+programming language implementations. The project was born out of a need to
+have a good libm for the Julia programming langage that worked consistently
+across compilers and operating systems, and in 32-bit and 64-bit
+environments.")
+ ;; See LICENSE.md for details.
+ (license (list license:expat
+ license:isc
+ license:bsd-2
+ license:public-domain
+ license:lgpl2.1+))))
+
(define-public atlas
(package
(name "atlas")