aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-03-25 19:20:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-03-26 07:54:55 +0100
commitaf5b817ea9f4320b4cbffc85b3f57223a5b9463c (patch)
tree80f8f2efe7864c3d79c326cc025458087b62ba7c /gnu/packages/maths.scm
parente4160d0585862ab7e4c0b941d69781be2466e056 (diff)
downloadguix-af5b817ea9f4320b4cbffc85b3f57223a5b9463c.tar.gz
guix-af5b817ea9f4320b4cbffc85b3f57223a5b9463c.zip
gnu: openblas: build for all supported CPUs.
* gnu/packages/maths.scm (openblas)[arguments]: Add "DYNAMIC_ARCH=1" to make flags. Remove "#:substitutable? #f".
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 49667cc71b..417af4a91b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1033,11 +1033,14 @@ constant parts of it.")
(build-system gnu-build-system)
(arguments
'(#:tests? #f ;no "check" target
- #:substitutable? #f ;force local build because of CPU detection
#:make-flags
(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
"SHELL=bash"
- "NO_LAPACK=1")
+ "NO_LAPACK=1"
+ ;; Build the library for all supported CPUs. This allows
+ ;; switching CPU targets at runtime with the environment variable
+ ;; OPENBLAS_CORETYPE=<type>, where "type" is a supported CPU type.
+ "DYNAMIC_ARCH=1")
;; no configure script
#:phases (alist-delete 'configure %standard-phases)))
(inputs