aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-04-11 12:14:59 +0200
committerLudovic Courtès <ludo@gnu.org>2024-04-11 12:17:30 +0200
commit68202bcc439dd4ec2a5c839b35a0631f27eb0a90 (patch)
treec51363552c2599af07fb15f313eabb55134f794a /gnu/packages/maths.scm
parentd564e04dedbba18744f1071b48b09f190ef4d5ad (diff)
downloadguix-68202bcc439dd4ec2a5c839b35a0631f27eb0a90.tar.gz
guix-68202bcc439dd4ec2a5c839b35a0631f27eb0a90.zip
gnu: pt-scotch: Include <stdint.h> so ‘parmetis.h’ is usable.
Fixes a bug when building ‘superlu-dist’ where ‘int32_t’ would be undefined. * gnu/packages/maths.scm (scotch)[source]: Add ‘snippet’. Change-Id: Id5beb2034d762727458821b93568e5b733184c00
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 03760f3f3e..92a9600e09 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2018, 2020, 2021 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2016-2023 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016-2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018, 2019, 2020, 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
@@ -4502,7 +4502,14 @@ implemented in ANSI C, and MPI for communications.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0rbc51albpd2923dkirpkj8rfkic6rsvwqqnv1mmsk391zhk3amr"))))
+ (base32 "0rbc51albpd2923dkirpkj8rfkic6rsvwqqnv1mmsk391zhk3amr"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(substitute* "src/libscotchmetis/library_parmetis.h"
+ (("typedef DUMMYINT SCOTCH_Num" all)
+ ;; 'DUMMYINT' is typically replaced by 'int32_t'. Include
+ ;; <stdint.h> to get that type definition.
+ (string-append "#include <stdint.h>\n" all "\n"))))))
(build-system cmake-build-system)
(inputs
(list zlib))