aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-04-12 23:46:58 +0200
committerLudovic Courtès <ludo@gnu.org>2014-04-12 23:46:58 +0200
commitc5cd288bc71667bfd5c63a5ba958de8f49815385 (patch)
tree6961c34dd8d1fa5abc70d081a2c4eb8b59cb8223 /gnu/packages/man.scm
parent6071b55e10b7b6e67d77ae058c8744834889e0b4 (diff)
downloadguix-c5cd288bc71667bfd5c63a5ba958de8f49815385.tar.gz
guix-c5cd288bc71667bfd5c63a5ba958de8f49815385.zip
gnu: Add Linux man-pages.
* gnu/packages/man.scm (man-pages): New variable.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 9be408a3d1..a6c2c1c0a8 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
;;;
;;; This file is part of GNU Guix.
@@ -110,6 +110,34 @@ accessed using the man command. It uses a Berkeley DB database in place of
the traditional flat-text whatis databases.")
(license gpl2+)))
+(define-public man-pages
+ (package
+ (name "man-pages")
+ (version "3.64")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kernel/linux/docs/man-pages/man-pages-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1p9zk130c852gqci6dyw57yaqx4v871n8n82kkccdpj7y63xr4bl"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (alist-delete 'configure %standard-phases)
+ #:tests? #f
+ #:make-flags (list (string-append "MANDIR="
+ (assoc-ref %outputs "out")
+ "/share/man"))))
+ (home-page "http://www.kernel.org/doc/man-pages/")
+ (synopsis "Development manual pages from the Linux project")
+ (description
+ "This package provides traditional Unix \"man pages\" documenting the
+Linux kernel and C library interfaces employed by user-space programs.")
+
+ ;; Each man page has its own license; some are GPLv2+, some are MIT/X11.
+ (license gpl2+)))
+
(define-public help2man
(package
(name "help2man")