aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-01 13:04:38 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-01 13:04:38 +0100
commit9ae7cee342db1abe9504ecba90da65c05694ab88 (patch)
tree9bfeac78402e8785a4c3a685dad310d5f1e465ce /gnu/packages/make-bootstrap.scm
parent67f6491bce972979201e39eb74bc01ab93455a55 (diff)
downloadguix-9ae7cee342db1abe9504ecba90da65c05694ab88.tar.gz
guix-9ae7cee342db1abe9504ecba90da65c05694ab88.zip
gnu: Switch to GCC 4.8 as the default compiler.
* gnu/packages/base.scm (gcc-boot0, cross-gcc-wrapper, gcc-final): Base on GCC-4.8. * gnu/packages/cross-base.scm (cross-gcc): Likewise. * gnu/packages/make-bootstrap.scm (package-with-relocatable-glibc, %gcc-static, %gcc-stripped): Likewise.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 8c148f7086..708cb39bb2 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -94,10 +94,10 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
("cross-binutils" ,(cross-binutils target))
,@%final-inputs))
`(("libc" ,(glibc-for-bootstrap))
- ("gcc" ,(package (inherit gcc-4.7)
+ ("gcc" ,(package (inherit gcc-4.8)
(inputs
`(("libc",(glibc-for-bootstrap))
- ,@(package-inputs gcc-4.7)))))
+ ,@(package-inputs gcc-4.8)))))
,@(fold alist-delete %final-inputs '("libc" "gcc")))))
(package-with-explicit-inputs p inputs
@@ -378,7 +378,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(define %gcc-static
;; A statically-linked GCC, with stripped-down functionality.
(package-with-relocatable-glibc
- (package (inherit gcc-4.7)
+ (package (inherit gcc-4.8)
(name "gcc-static")
(arguments
`(#:modules ((guix build utils)
@@ -386,7 +386,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(srfi srfi-1)
(srfi srfi-26)
(ice-9 regex))
- ,@(substitute-keyword-arguments (package-arguments gcc-4.7)
+ ,@(substitute-keyword-arguments (package-arguments gcc-4.8)
((#:guile _) #f)
((#:implicit-inputs? _) #t)
((#:configure-flags flags)
@@ -409,11 +409,11 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
("mpfr-source" ,(package-source mpfr))
("mpc-source" ,(package-source mpc))
("binutils" ,binutils)
- ,@(package-inputs gcc-4.7))))))
+ ,@(package-inputs gcc-4.8))))))
(define %gcc-stripped
;; The subset of GCC files needed for bootstrap.
- (package (inherit gcc-4.7)
+ (package (inherit gcc-4.8)
(name "gcc-stripped")
(build-system trivial-build-system)
(source #f)