aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-20 23:47:22 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-20 23:47:22 +0200
commit4db00e42109b6f8229259859deac35499eec9004 (patch)
tree7bec555f6813e5327f6d6268b3f654abdcd4cd0d /gnu/packages/make-bootstrap.scm
parentfba96c4885aa5b95c42120387db0450d9794508a (diff)
downloadguix-4db00e42109b6f8229259859deac35499eec9004.tar.gz
guix-4db00e42109b6f8229259859deac35499eec9004.zip
gnu: libgc: Always build with -DUSE_LIBC_PRIVATES.
* gnu/packages/bdw-gc.scm (libgc): Add `arguments' field. * gnu/packages/make-bootstrap.scm (%guile-static): Remove local `libgc'.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index de4e0dcbeb..b927d5db25 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -404,13 +404,7 @@
;; A statically-linked Guile that is relocatable--i.e., it can search
;; .scm and .go files relative to its installation directory, rather
;; than in hard-coded configure-time paths.
- (let* ((libgc (package (inherit libgc)
- (arguments
- ;; Make it so that we don't rely on /proc. This is
- ;; especially useful in an initrd run before /proc is
- ;; mounted.
- '(#:configure-flags '("CPPFLAGS=-DUSE_LIBC_PRIVATES")))))
- (guile (package (inherit guile-2.0)
+ (let* ((guile (package (inherit guile-2.0)
(name (string-append (package-name guile-2.0) "-static"))
(inputs
`(("patch/relocatable"