aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-08-22 13:56:21 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:48 +0200
commit2c51202a2a803853cf9844c6169087628d098955 (patch)
treedbdf88059a03a8b19418287476cf421ce314a421 /gnu/packages/make-bootstrap.scm
parent7cedba32486677ecace9fab3194917719b7438be (diff)
downloadguix-2c51202a2a803853cf9844c6169087628d098955.tar.gz
guix-2c51202a2a803853cf9844c6169087628d098955.zip
gnu: make-bootstrap: Ensure libm.a provides ‘fmod’ on i686.
Fixes <https://issues.guix.gnu.org/72725>. * gnu/packages/make-bootstrap.scm (glibc-for-bootstrap)[arguments]: Add ‘apply-libm-patch’ on i686. * gnu/packages/patches/glibc-2.39-fmod-libm-a.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Reported-by: Ricardo Wurmus <rekado@elephly.net> Change-Id: Iaffba0a9f424d8d80a8a5611df2d285d7d632d99
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 679aa46d60..91796efd0f 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -85,7 +85,18 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; and can use statically-linked NSS modules.
`(cons* "--disable-nscd" "--disable-build-nscd"
"--enable-static-nss"
- ,flags))))
+ ,flags))
+ ((#:phases phases #~%standard-phases)
+ ;; Apply i686-linux-specific patch.
+ (if (target-x86-32?)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'apply-libm-patch
+ (lambda _
+ (define patch
+ #$(local-file
+ (search-patch "glibc-2.39-fmod-libm-a.patch")))
+ (invoke "patch" "--force" "-p1" "-i" patch))))
+ phases))))
;; Remove the 'debug' output to allow bit-reproducible builds (when the
;; 'debug' output is used, ELF files end up with a .gnu_debuglink, which