aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-01 22:21:09 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-01 22:21:09 +0200
commit8de4131b2ddd11faa3394cf497484563068c9e7a (patch)
treeed4ed9e586c7236f09c109afdd416dac18ba8cc3 /gnu/packages/machine-learning.scm
parent15406013fe63f2ab238eec2d7a8adbc586806ac8 (diff)
parent45b7a8bfda5bde2e2daee4bec0ca092cd719d726 (diff)
downloadguix-8de4131b2ddd11faa3394cf497484563068c9e7a.tar.gz
guix-8de4131b2ddd11faa3394cf497484563068c9e7a.zip
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm37
1 files changed, 35 insertions, 2 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index f50398b555..3923573d57 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1159,7 +1159,7 @@ with a single function call.")
(define-public rxcpp
(package
(name "rxcpp")
- (version "4.1.0")
+ (version "4.1.1")
(source
(origin
(method git-fetch)
@@ -1167,7 +1167,7 @@ with a single function call.")
(url "https://github.com/ReactiveX/RxCpp")
(commit (string-append "v" version))))
(sha256
- (base32 "1rdpa3jlc181jd08nk437aar085h28i45s6nzrv65apb3xyyz0ij"))
+ (base32 "1blyjjw6szd74pckdc15ham9i48xf0vwwz5nhl9vyjfq8z7w3piy"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
@@ -1995,6 +1995,39 @@ optimization over awkward search spaces, which may include real-valued,
discrete, and conditional dimensions.")
(license license:bsd-3)))
+(define-public python-deepxde
+ (package
+ (name "python-deepxde")
+ (version "1.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "DeepXDE" version))
+ (sha256
+ (base32
+ "07bz3d7d698l0fhznw5l8p16b22d4ly7xq99vrgv48c722qr2r5b"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f ; there are no tests
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'sanity-check 'writable-home
+ ;; sanity-check writes ~/.deepxde/config.json to set
+ ;; the default backend.
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
+ ;; DeepXDE supported backends are TensorFlow (v1 and v2), PyTorch, JAX and
+ ;; PaddlePaddle. We test with PyTorch because we have it up to date.
+ (native-inputs (list python-pytorch python-setuptools-scm))
+ (propagated-inputs (list python-matplotlib python-numpy
+ python-scikit-learn python-scikit-optimize
+ python-scipy))
+ (home-page "https://deepxde.readthedocs.io/en/latest/")
+ (synopsis "Library for scientific machine learning")
+ (description "DeepXDE is a library for scientific machine learning and
+physics-informed learning. It includes implementations for the PINN
+(physics-informed neural networks), DeepONet (deep operator network) and
+MFNN (multifidelity neural network) algorithms.")
+ (license license:lgpl2.1+)))
+
;; There have been no proper releases yet.
(define-public kaldi
(let ((commit "be22248e3a166d9ec52c78dac945f471e7c3a8aa")