aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-10 22:51:59 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-10 23:00:43 +0100
commitfbc5e7fc40919a66a24855430f7b32a304579d0d (patch)
treef0f7b71955229289d8adafc3f62e46626386cb5c /gnu/packages/lisp.scm
parent376d957291ba21bb500b252493d53253ddc4a165 (diff)
downloadguix-fbc5e7fc40919a66a24855430f7b32a304579d0d.tar.gz
guix-fbc5e7fc40919a66a24855430f7b32a304579d0d.zip
gnu: packages: Remove x86_64-gnu next to i586-gnu from supported-systems.
* gnu/packages/golang.scm (go-1.16)[supported-systems]: Remove "x86_64-gnu". * gnu/packages/linux.scm (proot)[supported-systems]: Likewise. * gnu/packages/valgrind.scm (valgrind)[supported-systems]: Likewise. * gnu/packages/virtualization.scm (qemu)[supported-systems]: Likewise. * gnu/packages/heads.scm (musl-cross)[supported-systems]: Delete target-hurd? instead of remove'ing "i586-gnu". * gnu/packages/linux.scm (net-tools)[supported-systems]: Likewise. (libcap)[supported-systems]: Likewise. (fuse)[supported-systems]: Likewise. (kmod)[supported-systems]: Likewise. (lvm2)[supported-systems]: Likewise. (mdadm)[supported-systems]: Likewise. (proot)[supported-systems]: Likewise. * gnu/packages/lisp.scm (ecl)[supported-systems]: Likewise. (sbcl)[supported-systems]: Likewise. * gnu/packages/virtualization.scm (qemu)[supported-systems]: Likewise. Change-Id: I506e056b7aeb40f004fcc31ee85962cb065eac29
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d2e80faf11..82ab70fd70 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 David Pflug <david@pflug.io>
+;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -696,7 +697,7 @@ enough to play the original mainframe Zork all the way through.")
(files '("etc")))))
(home-page "https://ecl.common-lisp.dev/")
(synopsis "Embeddable Common Lisp")
- (supported-systems (delete "i586-gnu" %supported-systems))
+ (supported-systems (remove target-hurd? %supported-systems))
(description "ECL is an implementation of the Common Lisp language as
defined by the ANSI X3J13 specification. Its most relevant features are: a
bytecode compiler and interpreter, being able to compile Common Lisp with any
@@ -1506,7 +1507,7 @@ be built as a stand-alone REPL interpreter.")
(variable "XDG_CONFIG_DIRS")
(files '("etc")))))
(home-page "https://www.sbcl.org/")
- (supported-systems (delete "i586-gnu" %supported-systems))
+ (supported-systems (remove target-hurd? %supported-systems))
(synopsis "Common Lisp implementation")
(description "Steel Bank Common Lisp (SBCL) is a high performance Common
Lisp compiler. In addition to the compiler and runtime system for ANSI Common