aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-07-23 21:43:06 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-07-23 21:43:06 +0200
commitd726b954baaeff876ce9728e00920fa45f529f9a (patch)
tree4b767b7586a1082dd2691bc33c3e45ace044e6e5 /gnu/packages/lisp.scm
parent9a74a7db8626bc139307d115f5cec2648f5273ad (diff)
parente165a2492d73d37c8b95d6970d453b9d88911ee6 (diff)
downloadguix-d726b954baaeff876ce9728e00920fa45f529f9a.tar.gz
guix-d726b954baaeff876ce9728e00920fa45f529f9a.zip
Merge branch 'master' into core-updates
Conflicts: gnu/packages/ruby.scm
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index a2e0f0724d..4de4e9f9d6 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -369,6 +369,8 @@ high-level, object-oriented functional programming language. CLISP includes
an interpreter, a compiler, a debugger, and much more.")
(license license:gpl2+)))
+;; NOTE: SBCL 2.0.6 breaks named-readtables and consequently many Common Lisp packages.
+;; See https://github.com/melisgl/named-readtables/issues/19.
(define-public sbcl
(package
(name "sbcl")
@@ -397,12 +399,13 @@ an interpreter, a compiler, a debugger, and much more.")
;; ABCL and ECL (as well as CCL, CMUCL, CLISP and SBCL itself)
;;
;; CCL is not bootstrappable so it won't do. CLISP 2.49 seems to work.
- ;; ECL too. ECL builds SBCL about 20% slower than CLISP. As of
- ;; 2019-09-05, ECL was last updated in 2020 while CLISP was last updated
- ;; in 2010.
+ ;; ECL too. As of 2020-07-01, ECL was last updated in 2020 while CLISP
+ ;; was last updated in 2010, and both take about the same time to build SBCL.
;;
- ;; For now we stick to CLISP for all systems. We keep the `match' here to
- ;; make it easier to change the host compiler for various architectures.
+ ;; For now we stick to CLISP for all systems. We keep the `match' here
+ ;; to make it easier to change the host compiler for various
+ ;; architectures. Consider switching to ECL if it gets faster than CLISP
+ ;; (maybe post 2020 release).
`(,@(match (%current-system)
((or "x86_64-linux" "i686-linux")
`(("clisp" ,clisp)))