aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-13 17:21:32 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-13 17:21:32 +0200
commit15406013fe63f2ab238eec2d7a8adbc586806ac8 (patch)
tree8377d7c70a925f7c5ea4c04473c4eb547610b64b /gnu/packages/lisp.scm
parenta3ac317ab4a90f66ac65055fa26dee58ed2367b8 (diff)
parentdd4c1992103a65b8fbdc80fe07a9fe9be822769a (diff)
downloadguix-15406013fe63f2ab238eec2d7a8adbc586806ac8.tar.gz
guix-15406013fe63f2ab238eec2d7a8adbc586806ac8.zip
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index a7e06dd34c..37735020ad 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2017, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017-2019, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017-2019, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2019–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
@@ -993,7 +993,7 @@ the HTML documentation of TXR.")
(define-public txr
(package
(name "txr")
- (version "287")
+ (version "289")
(source
(origin
(method git-fetch)
@@ -1002,7 +1002,7 @@ the HTML documentation of TXR.")
(commit (string-append "txr-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0bwa40l5c0dnpcpfbysqbv8ch58sycbb31dnskmhr387jlv938dl"))))
+ (base32 "1jcz5iggp4mz5bzgnifr4xdpvz0sxa8cminynhdcs2jqr073xy8b"))))
(build-system gnu-build-system)
(arguments
(list #:configure-flags
@@ -1315,7 +1315,7 @@ assembler, PEG) is less than 1MB.")
(dirname
(search-input-file
inputs "include/stdlib.h"))))))
-
+
(for-each wrap-carp-program
(list "carp"
"carp-header-parse")))))))
@@ -1433,7 +1433,7 @@ executable Common Lisp image. It is similar to cl-launch and hu.dwim.build.")
(define-public eisl
(package
(name "eisl")
- (version "2.72")
+ (version "3.00")
(source
(origin
(method git-fetch)
@@ -1442,7 +1442,7 @@ executable Common Lisp image. It is similar to cl-launch and hu.dwim.build.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "12dc6b70dcfalyq3h5i7lmz39xh310k5p83x5q6j18knd6ql9ik9"))))
+ (base32 "0nppbzfdx4cjy72b4n0yk177i7063a0nhsrs9b1y45y4avbrbl00"))))
(build-system gnu-build-system)
(inputs
(list bash-minimal freeglut gdbm libiconv ncurses tcl tk))
@@ -1587,8 +1587,10 @@ be built as a stand-alone REPL interpreter.")
(inherit s7-bootstrap)
(name "s7")
(arguments
- (substitute-keyword-arguments (package-arguments s7-bootstrap)
- ((#:tests? _) #t)
+ (substitute-keyword-arguments
+ (strip-keyword-arguments
+ '(#:tests?)
+ (package-arguments s7-bootstrap))
((#:phases phases)
#~(modify-phases #$phases
(add-after 'unpack 'patch