aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-10-31 11:02:02 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2024-11-21 16:53:27 +0100
commitb6b439c24314580f27e14d62022d5a8b2083f757 (patch)
treea1ef4cbceba440fe2f404a15fcd1c5790b752d95 /gnu/packages/lisp-xyz.scm
parent7a95b9ad574584c73191855462f9ca00c22bf80e (diff)
downloadguix-b6b439c24314580f27e14d62022d5a8b2083f757.tar.gz
guix-b6b439c24314580f27e14d62022d5a8b2083f757.zip
gnu: cl-polymorphic-functions: Update to 0.5.2.
* gnu/packages/lisp-xyz.scm (sbcl-polymorphic-functions): Update to 0.5.2. [arguments]: Add 'fix-build' phase. Change-Id: Ic67ae27c7171127d93340c4c78c64fe71940f802
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 62883ca8c5..8f816b9a67 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -24361,7 +24361,7 @@ that should happen depending on compiler policy.")
(define-public sbcl-polymorphic-functions
(package
(name "sbcl-polymorphic-functions")
- (version "0.2.1")
+ (version "0.5.2")
(source
(origin
(method git-fetch)
@@ -24370,20 +24370,29 @@ that should happen depending on compiler policy.")
(commit (string-append "v" version))))
(file-name (git-file-name "cl-polymorphic-functions" version))
(sha256
- (base32 "161ylp3avmkylgfddp7i1kscv3bqx734jk1i97xhsbl7x83nin0h"))))
+ (base32 "1bawhbj5rh1q6qrcjnx48n78841mgri5n63pmicxxyhif2il0zq3"))))
(build-system asdf-build-system/sbcl)
(inputs
(list sbcl-alexandria
+ sbcl-cl-form-types
sbcl-closer-mop
sbcl-compiler-macro-notes
sbcl-ctype
sbcl-fiveam
- sbcl-cl-form-types
sbcl-introspect-environment
sbcl-slime-swank))
(arguments
;; Tests fail: https://github.com/digikar99/polymorphic-functions/issues/8
- '(#:tests? #f))
+ (list #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ (lambda _
+ ;; SBCL 2.4.10 doesn't allow user code to
+ ;; rebind *IN-COMPILATION-UNIT*.
+ (substitute* "src/nonlite/dispatch.lisp"
+ (("#\\+sbcl \\(sb-c::\\*in-compilation-unit\\* nil\\)")
+ "")))))))
(home-page "https://github.com/digikar99/polymorphic-functions/")
(synopsis "Function type to dispatch on types instead of classes")
(description