aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-11-20 13:28:33 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2024-11-20 15:10:04 +0100
commit0c386075244566748618734e9b5073059f598f89 (patch)
treec69398bd3c9a0ebef1ad515b05fbf09aa2207abd /gnu/packages/lisp-xyz.scm
parent72ef08da9d4cd811d59be95bebc0ea8492427587 (diff)
downloadguix-0c386075244566748618734e9b5073059f598f89.tar.gz
guix-0c386075244566748618734e9b5073059f598f89.zip
gnu: cl-in-memory-streams: Update to 2.0-1.a081214.
* gnu/packages/lisp-xyz.scm (sbcl-in-memory-streams): Update to 2.0-1.a081214. [inputs]: Add sbcl-bordeaux-threads. Change-Id: I6c69a64469e67e2337da343d462091d141c1277b
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 065100bbde..9fa7335b4d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18099,11 +18099,11 @@ floating point values to IEEE 754 binary representation.")
(sbcl-package->ecl-package sbcl-ieee-floats))
(define-public sbcl-in-memory-streams
- (let ((commit "bb4ce9c8c08479c9904f5d29f2b6187f264dc620")
+ (let ((commit "a0812140609d350e6d974711be6acd0566b360cc")
(revision "1"))
(package
(name "sbcl-in-memory-streams")
- (version (git-version "1.0" revision commit))
+ (version (git-version "2.0" revision commit))
(source
(origin
(method git-fetch)
@@ -18112,12 +18112,12 @@ floating point values to IEEE 754 binary representation.")
(commit commit)))
(file-name (git-file-name "cl-in-memory-streams" version))
(sha256
- (base32 "1fls1jnkf86wimip6f95y496sc4rxpsh2y65lgqsqpi0yda5xl2f"))))
+ (base32 "1mgdwgf98k5wsxrlvqjjkg6f8ass6gbhcbg1y489v17pwqjhbgaz"))))
(build-system asdf-build-system/sbcl)
(native-inputs
(list sbcl-fiveam))
(inputs
- (list sbcl-trivial-gray-streams))
+ (list sbcl-bordeaux-threads sbcl-trivial-gray-streams))
(synopsis "In-memory streams for any element type")
(description
"This Common Lisp library provides an implementation of in-memory input