aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-22 23:06:33 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-22 23:06:33 +0200
commitf07aa672fddd7b5405fc730ffebcda67daa71ae1 (patch)
tree52b2a3f246f5022ef7eaa7e20cb9aac067e10d05 /gnu/packages/linux.scm
parent52ac153e2a83035ce2bc875f9c414cb26db5f6fc (diff)
parentdd68dd137a4a70cde7e344bd969ef7849355d018 (diff)
downloadguix-f07aa672fddd7b5405fc730ffebcda67daa71ae1.tar.gz
guix-f07aa672fddd7b5405fc730ffebcda67daa71ae1.zip
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 29c2878d84..561275c05f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -379,7 +379,16 @@ providing the system administrator with some help in common tasks.")
(sha256
(base32
"1rpgghf7n0zx0cdy8hibr41wvkm2qp1yvd8ab1rxr193l1jmgcir"))
- (patches (list (search-patch "util-linux-perl.patch")))))
+ (patches (list (search-patch "util-linux-perl.patch")))
+ (modules '((guix build utils)))
+ (snippet
+ ;; We take the 'logger' program from GNU Inetutils, so remove
+ ;; it from here.
+ '(substitute* "misc-utils/Makefile.in"
+ (("PROGRAMS =(.*) logger(.*)" _ before after)
+ (string-append "PROGRAMS =" before " " after))
+ (("MANS =(.*) logger\\.1(.*)" _ before after)
+ (string-append "MANS =" before " " after))))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-use-tty-group"