aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-06-07 21:16:37 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-22 12:29:38 +0200
commite062d54240af140393dc8368b27611d31fb29441 (patch)
tree638da951cad157ad8fe7ab09d445be4be59bbc02 /gnu/packages/linux.scm
parent9b9148d8bb1e6cdb383172bf3201f81c9bb43258 (diff)
downloadguix-e062d54240af140393dc8368b27611d31fb29441.tar.gz
guix-e062d54240af140393dc8368b27611d31fb29441.zip
gnu: Add kmod.
* gnu/packages/linux.scm (kmod): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fb942cb68f..1a3e5a6d8d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
@@ -1189,3 +1190,35 @@ for systems using the Linux kernel. This includes commands such as
"The inotify-tools packages provides a C library and command-line tools
to use Linux' inotify mechanism, which allows file accesses to be monitored.")
(license gpl2+)))
+
+(define-public kmod
+ (package
+ (name "kmod")
+ (version "17")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://kernel.org/linux/utils/kernel/kmod/"
+ "kmod-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1yid3a9b64a60ybj66fk2ysrq5klnl0ijl4g624cl16y8404g9rv"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("xz" ,guix:xz)
+ ("zlib" ,guix:zlib)))
+ (arguments
+ `(#:tests? #f ; FIXME: Investigate test failures
+ #:configure-flags '("--with-xz" "--with-zlib")))
+ (home-page "https://www.kernel.org/")
+ (synopsis "Kernel module tools")
+ (description "kmod is a set of tools to handle common tasks with Linux
+kernel modules like insert, remove, list, check properties, resolve
+dependencies and aliases.
+
+These tools are designed on top of libkmod, a library that is shipped with
+kmod. The aim is to be compatible with tools, configurations and indices
+from the module-init-tools project.")
+ (license gpl2+))) ; library under lgpl2.1+