aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-12 19:46:20 -0400
committerMark H Weaver <mhw@netris.org>2015-04-12 19:46:20 -0400
commita153ff80c85c5aa426371a1b691395d953fc6a53 (patch)
treee5f00261299c9c18b4e2e57ac24104532e565e9f /gnu/packages/linux.scm
parentbe234128487306fd922c61fbb0162c53eb5fe6df (diff)
downloadguix-a153ff80c85c5aa426371a1b691395d953fc6a53.tar.gz
guix-a153ff80c85c5aa426371a1b691395d953fc6a53.zip
gnu: net-tools: Adapt to linux-libre-headers-3.14.x.
* gnu/packages/linux.scm (net-tools): Remove the HAVE_HWSTRIP and HAVE_HWTR options from the configuration.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f04a94b3a3..4a0f61ef22 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -920,10 +920,12 @@ manpages.")
;; Pretend we have everything...
(system "yes | make config")
- ;; ... except we don't have libdnet, so remove that
- ;; definition.
+ ;; ... except for the things we don't have.
+ ;; HAVE_AFDECnet requires libdnet, which we don't have.
+ ;; HAVE_HWSTRIP and HAVE_HWTR require kernel headers
+ ;; that have been removed.
(substitute* '("config.make" "config.h")
- (("^.*HAVE_AFDECnet.*$") ""))))
+ (("^.*HAVE_(AFDECnet|HWSTRIP|HWTR)[ =]1.*$") ""))))
(alist-cons-after
'install 'remove-redundant-commands
(lambda* (#:key outputs #:allow-other-keys)