aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-01-13 19:04:42 -0500
committerLeo Famulari <leo@famulari.name>2023-01-13 19:08:40 -0500
commit9ea37eb9f5329c213757bbfe5d9241cde8433858 (patch)
tree20fdd7378aae8ed3bd2a2c10ccece16af63cf561 /gnu/packages/linux.scm
parente1bad6d1d786b8a29fd3a0f14d069324e76d4651 (diff)
downloadguix-9ea37eb9f5329c213757bbfe5d9241cde8433858.tar.gz
guix-9ea37eb9f5329c213757bbfe5d9241cde8433858.zip
gnu: Remove linux-libre 6.0.
This kernel series is no longer supported upstream. * gnu/packages/linux.scm (linux-libre-6.0-version, linux-libre-6.0-gnu-revision, deblob-scripts-6.0, linux-libre-6.0-pristine-source, linux-libre-6.0-source, linux-libre-headers-6.0, linux-libre-6.0): Remove variables. * gnu/packages/aux-files/linux-libre/6.0-arm.conf, gnu/packages/aux-files/linux-libre/6.0-arm64.conf, gnu/packages/aux-files/linux-libre/6.0-i686.conf, gnu/packages/aux-files/linux-libre/6.0-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 0 insertions, 34 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4bb4623595..676a339a7d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -495,21 +495,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-6.1)))
-(define-public linux-libre-6.0-version "6.0.19")
-(define-public linux-libre-6.0-gnu-revision "gnu")
-(define deblob-scripts-6.0
- (linux-libre-deblob-scripts
- linux-libre-6.0-version
- linux-libre-6.0-gnu-revision
- (base32 "0iwbjrgiwch5v1xpnm9wk9zqw2v6lxja0k8yj2x0amxc9ma68176")
- (base32 "16g2bin3xay30zfss1vlb7pwcss5giaxaksp4v1gk05wn51wjrqr")))
-(define-public linux-libre-6.0-pristine-source
- (let ((version linux-libre-6.0-version)
- (hash (base32 "01q2sciv3l9brnsfcv9knx1ps3hq9rk1a08iqk3vscg3waq7xqxb")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-6.0)))
-
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
@@ -622,12 +607,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
%linux-libre-arm-export-__sync_icache_dcache-patch
(search-patch "linux-libre-infodocs-target.patch"))))
-(define-public linux-libre-6.0-source
- (source-with-patches linux-libre-6.0-pristine-source
- (list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch
- (search-patch "linux-libre-infodocs-target.patch"))))
-
(define-public linux-libre-5.15-source
(source-with-patches linux-libre-5.15-pristine-source
(list %boot-logo-patch
@@ -738,11 +717,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
linux-libre-6.1-gnu-revision
linux-libre-6.1-source))
-(define-public linux-libre-headers-6.0
- (make-linux-libre-headers* linux-libre-6.0-version
- linux-libre-6.0-gnu-revision
- linux-libre-6.0-source))
-
(define-public linux-libre-headers-5.15
(make-linux-libre-headers* linux-libre-5.15-version
linux-libre-5.15-gnu-revision
@@ -1082,14 +1056,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
"aarch64-linux" "powerpc64le-linux" "riscv64-linux")
#:configuration-file kernel-config))
-(define-public linux-libre-6.0
- (make-linux-libre* linux-libre-6.0-version
- linux-libre-6.0-gnu-revision
- linux-libre-6.0-source
- '("x86_64-linux" "i686-linux" "armhf-linux"
- "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
- #:configuration-file kernel-config))
-
(define-public linux-libre-version linux-libre-6.1-version)
(define-public linux-libre-gnu-revision linux-libre-6.1-gnu-revision)
(define-public linux-libre-pristine-source linux-libre-6.1-pristine-source)