aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-15 21:34:38 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-15 22:56:10 -0400
commit923d23a23c3d980d4a6f1c4a6956d1b9e480385c (patch)
treec9b4a1410524d4b0916408c5b97579d54688d5d5 /gnu/packages/linux.scm
parent9f3a929828930c3e5dfc6f6e7a3516da6bb7cd00 (diff)
downloadguix-923d23a23c3d980d4a6f1c4a6956d1b9e480385c.tar.gz
guix-923d23a23c3d980d4a6f1c4a6956d1b9e480385c.zip
gnu: efibootmgr: Update to 18.
* gnu/packages/linux.scm (efibootmgr): Update to 18. [source]: Delete snippet, modules and patches fields. * gnu/packages/patches/efibootmgr-remove-extra-decl.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 8 insertions, 17 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5397c53fda..8b37c4e52e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7266,7 +7266,7 @@ interface to the variable facility of UEFI boot firmware.")
(define-public efibootmgr
(package
(name "efibootmgr")
- (version "17")
+ (version "18")
(source
(origin
(method git-fetch)
@@ -7275,16 +7275,7 @@ interface to the variable facility of UEFI boot firmware.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1niicijxg59rsmiw3rsjwy4bvi1n42dynvm01lnp9haixdzdpq03"))
- (patches (search-patches "efibootmgr-remove-extra-decl.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Cast the first argument to the correct type. Extracted
- ;; from upstream commit e8ce9fecebd15adb4.
- (substitute* '("src/efibootdump.c" "src/efibootmgr.c")
- (("efidp_format_device_path\\(text_path,")
- "efidp_format_device_path((unsigned char *)text_path,"))))))
+ (base32 "1j19m3dngcb7jl88ib32phbh5r7c02dhhakq8jk6z7y408c111hd"))))
(build-system gnu-build-system)
(arguments
(list
@@ -7299,12 +7290,12 @@ interface to the variable facility of UEFI boot firmware.")
;; nothing else is specified on the command line.
"EFIDIR=gnu")
#$(if (%current-target-system)
- #~(list
- (string-append "CC=" #$(cc-for-target))
- (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
- (string-append "EXTRAINCDIRS="
- #$(this-package-input "efivar") "/include"))
- #~'()))
+ #~(list
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
+ (string-append "EXTRAINCDIRS="
+ #$(this-package-input "efivar") "/include"))
+ #~'()))
#:phases #~(modify-phases %standard-phases (delete 'configure))))
(native-inputs
(list pkg-config))