aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-26 16:29:18 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 22:58:33 +0200
commit879c71edf40591955a6093a102f5d38e171e4f5f (patch)
treefbb8425b59e59ca8fafc90e9cc2743088134b3f4 /gnu/packages/linux.scm
parent1c3fe0e491a09e62f487b550b8f6d4fa26e888bd (diff)
downloadguix-879c71edf40591955a6093a102f5d38e171e4f5f.tar.gz
guix-879c71edf40591955a6093a102f5d38e171e4f5f.zip
gnu: util-linux: Update to 2.37.4.
* gnu/packages/linux.scm (util-linux): Update to 2.37.4. [replacement]: Remove. (util-linux/fixed): Remove variable. * gnu/packages/patches/util-linux-CVE-2021-3995.patch, gnu/packages/patches/util-linux-CVE-2021-3996.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm20
1 files changed, 2 insertions, 18 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6c04b4baec..b5b065d931 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1819,8 +1819,7 @@ providing the system administrator with some help in common tasks.")
(define-public util-linux
(package
(name "util-linux")
- (replacement util-linux/fixed)
- (version "2.37.2")
+ (version "2.37.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/utils/"
@@ -1828,7 +1827,7 @@ providing the system administrator with some help in common tasks.")
"util-linux-" version ".tar.xz"))
(sha256
(base32
- "1ng9517c37mdp858425a4zyybma7dh7jrpd6z1z61yz7mb0n81va"))
+ "10svcnsqmrsd660bzcm7k6dm8sa7hkknhr3bag1nccwimlb6jkk3"))
(patches (search-patches "util-linux-tests.patch"))
(modules '((guix build utils)))
(snippet
@@ -1972,21 +1971,6 @@ block devices, UUIDs, TTYs, and many other tools.")
(modify-inputs (package-inputs util-linux)
(prepend eudev)))))
-;; This is mostly equivalent to the upstream release version v2.37.3, except
-;; that the upstream tarball was generated improperly, which breaks the build.
-;; There will not be a v2.37.3-fixed release or anything like that to fix it:
-;; https://github.com/util-linux/util-linux/issues/1577
-(define-public util-linux/fixed
- (hidden-package
- (package
- (inherit util-linux)
- (source (origin
- (inherit (package-source util-linux))
- (patches (append (search-patches "util-linux-CVE-2021-3995.patch"
- "util-linux-CVE-2021-3996.patch")
- (origin-patches (package-source util-linux)))))))))
-
-
(define-public ddate
(package
(name "ddate")