aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-22 18:48:00 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-22 18:48:00 +0200
commit8655a714457dbf1cde45979507012d9515614028 (patch)
tree7712625328f45794ccda9baa730a4825bb2efb47 /gnu/packages/linux.scm
parenta589049e141588ebcf4079116e378d60b779f6b4 (diff)
parent2af3f5eef045f7d177cc394c89be069bac895688 (diff)
downloadguix-8655a714457dbf1cde45979507012d9515614028.tar.gz
guix-8655a714457dbf1cde45979507012d9515614028.zip
Merge branch master into core-updates
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm103
1 files changed, 58 insertions, 45 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 53b341d7c6..e17e1ef42d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -160,6 +160,7 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages groff)
#:use-module (gnu packages selinux)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages swig)
#:use-module (guix platform)
#:use-module (guix build-system cmake)
@@ -351,17 +352,17 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
-(define-public linux-libre-5.17-version "5.17.12")
+(define-public linux-libre-5.17-version "5.17.15")
(define-public linux-libre-5.17-gnu-revision "gnu")
(define deblob-scripts-5.17
(linux-libre-deblob-scripts
linux-libre-5.17-version
linux-libre-5.17-gnu-revision
(base32 "08ip5g827f30qzb3j2l19zkbdqv00sij46nbrjg75h5kkasdbfgr")
- (base32 "1zd4ds6ha4a2acqnalp234r2m9rz9p30qmy1aqri78i06aw7flwn")))
+ (base32 "1654fibbwnbcgnikn1qqa5igd2j90kslbb3pshph5wpj052cvgjy")))
(define-public linux-libre-5.17-pristine-source
(let ((version linux-libre-5.17-version)
- (hash (base32 "0yr8xfds5l1s3lk8qk67mgy0l4yh2jfvjc7xwrfws3ci020ss9a2")))
+ (hash (base32 "0a5n1lb43nhnhwjwclkk3dqp2nxsx5ny7zfl8idvzshf94m9472a")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.17)))
@@ -369,37 +370,37 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-5.15-version "5.15.44")
+(define-public linux-libre-5.15-version "5.15.47")
(define-public linux-libre-5.15-gnu-revision "gnu")
(define deblob-scripts-5.15
(linux-libre-deblob-scripts
linux-libre-5.15-version
linux-libre-5.15-gnu-revision
(base32 "1n57mz5agvf1d0ggbg080d7hvx8p9y0iqxkq4ypg10a7n96zy7y5")
- (base32 "0gs92qbpvirwd02rpwwnja7771z2azbiy9ppy9ynpr14lxmzxnnh")))
+ (base32 "17xsn91h0c2d8igpzgmjm1g58nfpihlhgg9wm8zbfyd5g4airs8f")))
(define-public linux-libre-5.15-pristine-source
(let ((version linux-libre-5.15-version)
- (hash (base32 "1p1jz0lxmzyj0c51afqghylg9kblk8zmlw92zq6bsn37wlwbrylv")))
+ (hash (base32 "1700js21yimx8rz4bsglszry564l2ycmmcr36rdqspzbmlx5w8wb")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.15)))
-(define-public linux-libre-5.10-version "5.10.119")
+(define-public linux-libre-5.10-version "5.10.122")
(define-public linux-libre-5.10-gnu-revision "gnu1")
(define deblob-scripts-5.10
(linux-libre-deblob-scripts
linux-libre-5.10-version
linux-libre-5.10-gnu-revision
(base32 "0mw7qn77y9c6wrnw4rjvf75cpm1w6n1aqqhf8cnghcb97p2yxxrf")
- (base32 "1xyhz0dyrkg2avz382ly3dzpa5v89x49gfzx80c1drpwsk7jg6gp")))
+ (base32 "1ryfc8fppigssrzz5lfbqgli49cgs3lmf0yh46lpi2k0j2x30qcc")))
(define-public linux-libre-5.10-pristine-source
(let ((version linux-libre-5.10-version)
- (hash (base32 "04952zaz2kfwf7agy4laz50f9sl3mrnpqlbwbj84q1xpl9akwd9y")))
+ (hash (base32 "0h0gfi3p1dd4p8xxklrl8sc3rv4xd08q7nv0i4m166w8188v62wj")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.10)))
-(define-public linux-libre-5.4-version "5.4.196")
+(define-public linux-libre-5.4-version "5.4.198")
(define-public linux-libre-5.4-gnu-revision "gnu1")
(define deblob-scripts-5.4
(linux-libre-deblob-scripts
@@ -409,12 +410,12 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "05i286d98fm2pdf9724x1dsmfcm7gsd7yyyvxqlpisyj1kx14hda")))
(define-public linux-libre-5.4-pristine-source
(let ((version linux-libre-5.4-version)
- (hash (base32 "1x5irgki792f21hm5146xary0260cl9r475kvw8vm9w32vyx18ig")))
+ (hash (base32 "0wvscr5wia2xdiqfxxdwl8kxf1s085qdj5h4423mraj7dh6l0ihh")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.4)))
-(define-public linux-libre-4.19-version "4.19.245")
+(define-public linux-libre-4.19-version "4.19.247")
(define-public linux-libre-4.19-gnu-revision "gnu1")
(define deblob-scripts-4.19
(linux-libre-deblob-scripts
@@ -424,12 +425,12 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "1dnjgx1nmawm9gm0yf15nl80nmg7hy7q2vl3jxjbwj6hlrfv5dmx")))
(define-public linux-libre-4.19-pristine-source
(let ((version linux-libre-4.19-version)
- (hash (base32 "1s58qci6xhmss12glzkqk41kp60pqmzh4d84kyz4m4nf4xhdvzcr")))
+ (hash (base32 "136gmsmvgb2nid4by2ld003w06lsr7hgn9ajx0wfziag7pfnjsv2")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.19)))
-(define-public linux-libre-4.14-version "4.14.281")
+(define-public linux-libre-4.14-version "4.14.283")
(define-public linux-libre-4.14-gnu-revision "gnu1")
(define deblob-scripts-4.14
(linux-libre-deblob-scripts
@@ -439,12 +440,12 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "1dnjgx1nmawm9gm0yf15nl80nmg7hy7q2vl3jxjbwj6hlrfv5dmx")))
(define-public linux-libre-4.14-pristine-source
(let ((version linux-libre-4.14-version)
- (hash (base32 "0pivb1m2cwqnlm8bhd4ccnlq9pwp2r5lmn77gp91k6vbjv3gkqis")))
+ (hash (base32 "191gybhnck4mh9yjzwgv1crrbxjc90p12bcif721rbs6xzszmxzh")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.14)))
-(define-public linux-libre-4.9-version "4.9.316")
+(define-public linux-libre-4.9-version "4.9.318")
(define-public linux-libre-4.9-gnu-revision "gnu1")
(define deblob-scripts-4.9
(linux-libre-deblob-scripts
@@ -454,7 +455,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "14jyn2yrbm6ayp0bszs4f9jy3p1qkrj5p5gf5c42spr67aa2lv2v")))
(define-public linux-libre-4.9-pristine-source
(let ((version linux-libre-4.9-version)
- (hash (base32 "05yd7djm6dcxv3vaylhmj3p0yml421azv8qabmhv4ric1f99idjp")))
+ (hash (base32 "09czsc0ynyw068yczs9qx4cliqmrh5hvz93c77lhh014wn02pba4")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.9)))
@@ -3694,7 +3695,7 @@ for systems using the Linux kernel. This includes commands such as
(define-public inotify-tools
(package
(name "inotify-tools")
- (version "3.20.11.0")
+ (version "3.22.6.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3703,7 +3704,7 @@ for systems using the Linux kernel. This includes commands such as
(file-name (git-file-name name version))
(sha256
(base32
- "1m8avqccrhm38krlhp88a7v949f3hrzx060bbrr5dp5qw2nmw9j2"))))
+ "1j9j8k5zjp8m4cl53zjncnll9z4dnvzr4ygmfcjk0ci81i59b18i"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake libtool))
@@ -5575,7 +5576,7 @@ and copy/paste text in the console and in xterm.")
(define-public btrfs-progs
(package
(name "btrfs-progs")
- (version "5.15.1")
+ (version "5.18.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/kernel/"
@@ -5583,7 +5584,7 @@ and copy/paste text in the console and in xterm.")
"btrfs-progs-v" version ".tar.xz"))
(sha256
(base32
- "085rg9p7kifhh8kjyyhs38y86srwk820s6v07min5gb177rzhc32"))))
+ "0mbj3j2fpjds9i9gm8kk8a20yjacc562ibd1v9a96bpmrxfag63f"))))
(build-system gnu-build-system)
(outputs '("out"
"static")) ; static versions of the binaries in "out"
@@ -5628,21 +5629,19 @@ and copy/paste text in the console and in xterm.")
("zstd" ,zstd "lib")
("zstd:static" ,zstd "static")))
(native-inputs `(("pkg-config" ,pkg-config)
- ("asciidoc" ,asciidoc)
- ("python" ,python)
- ("xmlto" ,xmlto)
;; For building documentation.
- ("libxml2" ,libxml2)
- ("docbook-xsl" ,docbook-xsl)
+ ("python-sphinx" ,python-sphinx)
;; For tests.
("acl" ,acl)
- ("which" ,which)
("dmsetup" ,lvm2)
- ;; The tests need 'grep' with perl regexp support.
- ("grep" ,grep)))
+ ("grep" ,grep) ; need Perl regexp support
+ ("libaio" ,libaio)
+ ("liburing" ,liburing)
+ ("util-linux" ,util-linux) ; for fallocate
+ ("which" ,which)))
(home-page "https://btrfs.wiki.kernel.org/index.php/Main_Page")
(synopsis "Create and manage btrfs copy-on-write file systems")
- (description "Btrfs is a @dfn{copy-on-write} (CoW) file system for Linux
+ (description "Btrfs is a @acronym{CoW, copy-on-write} file system for Linux
aimed at implementing advanced features while focusing on fault tolerance,
repair and easy administration.")
;; GPL2+: crc32.c, radix-tree.c, raid6.c, rbtree.c.
@@ -6343,7 +6342,7 @@ The collection contains a set of bandwidth and latency benchmark such as:
(package
(name "rng-tools")
(home-page "https://github.com/nhorman/rng-tools")
- (version "6.14")
+ (version "6.15")
(source (origin
(method git-fetch)
(uri (git-reference (url home-page)
@@ -6351,7 +6350,7 @@ The collection contains a set of bandwidth and latency benchmark such as:
(file-name (git-file-name name version))
(sha256
(base32
- "1hrbm4y7fbzkg5j2f7vpj19ri2ff2lp77al17fhi4mv0bvdfjd9m"))))
+ "0i00if7xknpm0dhkrm60rxzyyvq0vdibq7dvsd2ncm9pg098qvwj"))))
(build-system gnu-build-system)
(arguments
`(;; Disable support for various hardware entropy sources as they need
@@ -6359,12 +6358,19 @@ The collection contains a set of bandwidth and latency benchmark such as:
;; increase closure size.
#:configure-flags '("--without-nistbeacon"
"--without-pkcs11"
- "--without-rtlsdr")))
+ "--without-rtlsdr")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-failing-test
+ (lambda _
+ (substitute* "tests/Makefile"
+ ;; This test requires a hwrng, rdrand, or tpm device.
+ ;; Worse, it appears to fail if that isn't sufficiently random.
+ (("\\brngtestjitter\\.sh\\b") " ")))))))
(native-inputs
(list autoconf automake pkg-config))
(inputs
- `(("libsysfs" ,sysfsutils)
- ("openssl" ,openssl)))
+ (list sysfsutils openssl))
(synopsis "Random number generator daemon")
(description
"Monitor a hardware random number generator, and supply entropy
@@ -7247,14 +7253,14 @@ re-use code and to avoid re-inventing the wheel.")
(define-public libnftnl
(package
(name "libnftnl")
- (version "1.2.1")
+ (version "1.2.2")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://netfilter.org/libnftnl/"
"libnftnl-" version ".tar.bz2"))
(sha256
- (base32 "0z4khm2mnys9mcl8ckwf19cw20jgrv8650nfncy3xcgs2k2aa23m"))))
+ (base32 "02kdxp4l1ds5lpkw6rxv6f7icc70am6ik3p9z5l8v48mkm7h1z4y"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))
@@ -7289,7 +7295,7 @@ used by nftables.")
(define-public nftables
(package
(name "nftables")
- (version "1.0.2")
+ (version "1.0.4")
(source
(origin
(method url-fetch)
@@ -7298,9 +7304,7 @@ used by nftables.")
(string-append "https://www.nftables.org/projects/nftables"
"/files/nftables-" version ".tar.bz2")))
(sha256
- (base32 "00jcjn1pl7qyqpg8pd4yhlkys7wbj4vkzgg73n27nmplzips6a0b"))
- (patches
- (search-patches "nftables-fix-makefile.patch"))))
+ (base32 "0ddsdj6zs78hndffl3iikpa1wzjxcpmr3xqcq4la71gnl7zb2zwj"))))
(build-system gnu-build-system)
(arguments `(#:configure-flags
'("--disable-static"
@@ -9095,7 +9099,7 @@ kernel side implementation.")
(define-public erofs-utils
(package
(name "erofs-utils")
- (version "1.4")
+ (version "1.5")
(source
(origin
(method git-fetch)
@@ -9104,7 +9108,7 @@ kernel side implementation.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1ygaw69pfz2hfzw9cqzg9rfnjzrdbfkwsiinz6qs2h56dssjz0y9"))))
+ (base32 "0rgkw3b924xdg49v3qi8a10w41zfk276wb6fp71lb9q9cfc81idw"))))
(build-system gnu-build-system)
(inputs
(list lz4
@@ -9203,7 +9207,7 @@ older system-wide @file{/sys} interface.")
(define-public libtree
(package
(name "libtree")
- (version "3.0.2")
+ (version "3.1.1")
(source
(origin
(method git-fetch)
@@ -9212,7 +9216,7 @@ older system-wide @file{/sys} interface.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "072624anz9g01mp5vfkahfmzy0nb7axg5rwk3n1yrdm4hr3d4zrb"))))
+ (base32 "1jbc60cslzcfxk9jwva51ncr1zl1nz0fkgfjdckgv81is11nswmb"))))
(arguments
(list #:make-flags
;; NOTE: Official documentation recommends to build libtree with
@@ -9221,6 +9225,15 @@ older system-wide @file{/sys} interface.")
(string-append "PREFIX=" #$output))
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ ;; XXX: '08_nodeflib' fails as 'libtree' returns a non-zero
+ ;; code in one of the tests.
+ ;;
+ ;; See <https://github.com/haampie/libtree/issues/80>).
+ (lambda _
+ (substitute* "tests/08_nodeflib/Makefile"
+ (("! ../../libtree -vvv exe_b")
+ "../../libtree -vvv exe_b"))))
(delete 'configure))))
(build-system gnu-build-system)
(home-page "https://github.com/haampie/libtree")