aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-13 22:13:00 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-13 22:14:30 +0100
commit7c594a2c2fe7ae34b64ae61ebda41645c0e1c52c (patch)
tree5b1e2625e57f3cb48086275f19c74319f7d4740d /gnu/packages/linux.scm
parent524f4becffd6a22318d3d28a97e497ef643c8ae0 (diff)
downloadguix-7c594a2c2fe7ae34b64ae61ebda41645c0e1c52c.tar.gz
guix-7c594a2c2fe7ae34b64ae61ebda41645c0e1c52c.zip
gnu: e2fsprogs: Install libext2fs.
* gnu/packages/linux.scm (e2fsprogs)[source]: Add 'snippet'. [arguments]: Add --enable-elf-shlibs to #:configure-flags. Add #:make-flags.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3a6c44ea69..7199cca521 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -511,16 +511,28 @@ slabtop, and skill.")
version ".tar.gz"))
(sha256
(base32
- "0ibkkvp6kan0hn0d1anq4n2md70j5gcm7mwna515w82xwyr02rfw"))))
+ "0ibkkvp6kan0hn0d1anq4n2md70j5gcm7mwna515w82xwyr02rfw"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "MCONFIG.in"
+ (("INSTALL_SYMLINK = /bin/sh")
+ "INSTALL_SYMLINK = sh")))))
(build-system gnu-build-system)
(inputs `(("util-linux" ,util-linux)))
(native-inputs `(("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo))) ; for the libext2fs Info manual
+ ("texinfo" ,texinfo))) ;for the libext2fs Info manual
(arguments
'(;; The 'blkid' command and library are already provided by util-linux,
;; which is the preferred source for them (see, e.g.,
;; <http://git.buildroot.net/buildroot/commit/?id=e1ffc2f791b336339909c90559b7db40b455f172>.)
- #:configure-flags '("--disable-blkid")
+ #:configure-flags '("--disable-blkid"
+
+ ;; Install libext2fs et al.
+ "--enable-elf-shlibs")
+
+ #:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))
#:phases (alist-cons-before
'configure 'patch-shells