aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-09 00:13:50 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-09 00:13:50 +0100
commit60a366ec7aa777d61cd349fad5f9f32cbdb642dc (patch)
tree744084f199e795f7402ce8c244c501df9f0d709d /gnu/packages/linux.scm
parent907eeac2e7d5d9c10b65038d486876e577c80d85 (diff)
downloadguix-60a366ec7aa777d61cd349fad5f9f32cbdb642dc.tar.gz
guix-60a366ec7aa777d61cd349fad5f9f32cbdb642dc.zip
gnu: util-linux: Rename udev variant.
Some packages propagate util-linux, so make sure that that manifests and similar choose the same version to avoid conflicts. * gnu/packages/linux.scm (util-linux)[properties]: Remove. (util-linux+udev)[name]: Set to "util-linux-with-udev". [properties]: Remove.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3c720f32fc..ee571f12ad 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1182,9 +1182,6 @@ providing the system administrator with some help in common tasks.")
utilities. It provides dmesg and includes tools for working with file systems,
block devices, UUIDs, TTYs, and many other tools.")
- ;; Hide the package so that end users get the udev-enabled variant below.
- (properties '((hidden? . #t)))
-
;; Note that util-linux doesn't use the same license for all the
;; code. GPLv2+ is the default license for a code without an
;; explicitly defined license.
@@ -1197,10 +1194,10 @@ block devices, UUIDs, TTYs, and many other tools.")
(define-public util-linux+udev
(package/inherit
util-linux
+ (name "util-linux-with-udev")
(inputs
`(("udev" ,eudev)
- ,@(package-inputs util-linux)))
- (properties (alist-delete 'hidden? (package-properties util-linux)))))
+ ,@(package-inputs util-linux)))))
(define-public ddate
(package
46a5c9288f54753b0f158f9c4b8abc'>gnu: copyq: Update to 7.0.0....kiasoc5 2023-04-09gnu: Remove extraneous #:meson build arguments....Maxim Cournoyer 2023-04-03gnu: wvkbd: Update to 0.13....Tobias Kortkamp 2023-03-26gnu: Add physlock....Sergey Trofimov 2023-03-21gnu: Add xforms-gl....Jake Leporte 2023-03-21gnu: Add xforms....Jake Leporte 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-17gnu: bemenu: Update to 0.6.14....Yovan Naumovski 2023-03-14gnu: libdrm: Update configure-flags....Efraim Flashner 2023-03-14gnu: clipmenu: Improve package style....EuAndreh via Guix-patches via 2023-03-14gnu: clipmenu: Update to 6.2.0....EuAndreh via Guix-patches via 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Christopher Baines 2023-02-24gnu: Add tofi....Yovan Naumovski 2023-02-19gnu: Use HTTPS package home pages wherever possible....Tobias Geerinckx-Rice 2023-02-18gnu: Add nwg-launchers....Sughosha via Guix-patches via 2023-02-17gnu: Add clipman....Wamm K. D 2023-02-01gnu: libwacom: Update to 2.6.0....Morgan Smith 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates...Efraim Flashner 2023-01-26gnu: Add wl-color-picker....Sughosha 2023-01-15gnu: arandr: Remove input labels....Tobias Geerinckx-Rice 2023-01-15gnu: arandr: Truth is obsolete....Tobias Geerinckx-Rice 2023-01-15gnu: arandr: Update to 0.1.11....Tobias Geerinckx-Rice