aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2023-10-10 22:17:44 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2023-10-10 23:38:23 +0200
commit5a8f9d32f5196263bc50c2059bac4c4226784a59 (patch)
treed888e7296d9f8be36457b99ba2cb0b24c22fd653 /gnu/packages/linux.scm
parentfc6c910f797ea232f6019c4ca5dbd105f78928df (diff)
downloadguix-5a8f9d32f5196263bc50c2059bac4c4226784a59.tar.gz
guix-5a8f9d32f5196263bc50c2059bac4c4226784a59.zip
gnu: Add ryzen-smu.
* gnu/packages/linux.scm (ryzen-smu): New variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c993e7b9bb..66971df04b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -10506,3 +10506,26 @@ against the several transient execution CVEs that were published since early
(description "The primary purpose of Csmith is to find compiler bugs with
random programs using differential testing.")
(license license:bsd-4)))
+
+(define-public ryzen-smu
+ (package
+ (name "ryzen-smu")
+ (version "0.1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/leogx9r/ryzen_smu.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "010la2a8zp7rljlg5ssc9ragzva4ca05gvzlicjagl508659d2wz"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (synopsis "System Management Unit driver for AMD Ryzen processors")
+ (description "This package provides a way to access the
+System Management Unit for certain AMD Ryzen processors.
+This includes access to the System Management Network.")
+ (home-page "https://gitlab.com/leogx9r/ryzen_smu")
+ (license license:gpl2)))