aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-04 16:00:05 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-05 10:37:59 +0800
commit0a588bf95668bbc66e6924f16db7f477c83ce217 (patch)
treecf927b2951ce747946d9e9f34b250eb4a518fb7f /gnu/packages/linux.scm
parent6ef1c223aa9614da1714fa60c538fac81dd9c734 (diff)
downloadguix-0a588bf95668bbc66e6924f16db7f477c83ce217.tar.gz
guix-0a588bf95668bbc66e6924f16db7f477c83ce217.zip
gnu: Add libraw1394.
* gnu/packages/linux.scm (libraw1394): New variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 38b940d071..3e796552ef 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2001,3 +2001,26 @@ also contains the libsysfs library.")
information, and set the CPU frequency if supported, using the cpufreq
capabilities of the Linux kernel.")
(license gpl2)))
+
+(define-public libraw1394
+ (package
+ (name "libraw1394")
+ (version "2.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kernel.org/linux/libs/ieee1394/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0kwnf4ha45c04mhc4yla672aqmvqqihxix1gvblns5cd2pc2cc8b"))))
+ (build-system gnu-build-system)
+ (home-page "https://ieee1394.wiki.kernel.org/index.php/Main_Page")
+ (synopsis "Interface library for the Linux IEEE1394 drivers")
+ (description
+ "Libraw1394 is the only supported interface to the kernel side raw1394 of
+the Linux IEEE-1394 subsystem, which provides direct access to the connected
+1394 buses to user space. Through libraw1394/raw1394, applications can directly
+send to and receive from other nodes without requiring a kernel driver for the
+protocol in question.")
+ (license lgpl2.1+)))