aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-08 14:47:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-08 20:05:05 +0200
commitc73330838e7f81fdfcfcf371e0a8a03bb73a15f5 (patch)
tree274920821030a2545d9f6786f3c4fa850de3352a /gnu/packages/linphone.scm
parent9ff2f971cce2a0b4cd61205eeb1c37e7c39b941d (diff)
downloadguix-c73330838e7f81fdfcfcf371e0a8a03bb73a15f5.tar.gz
guix-c73330838e7f81fdfcfcf371e0a8a03bb73a15f5.zip
gnu: mediastreamer2: Drop input labels.
* gnu/packages/linphone.scm (mediastreamer2)[native-inputs]: Drop package labels. [inputs]: Same.
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm57
1 files changed, 27 insertions, 30 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index d489d03e4a..bc4049b8d4 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -652,37 +652,34 @@ API. It also comprises a simple HTTP/HTTPS client implementation.")
;; "Player"
"TextStream"))))))))
(native-inputs
- `(("dot" ,graphviz)
- ("doxygen" ,doxygen)
- ("python" ,python-wrapper)
- ("xorg-server" ,xorg-server-for-tests)))
+ (list graphviz doxygen python-wrapper xorg-server-for-tests))
(inputs
- `(("alsa" ,alsa-lib)
- ("bcg729" ,bcg729)
- ("bcmatroska2" ,bcmatroska2)
- ("bctoolbox" ,bctoolbox)
- ("ffmpeg" ,ffmpeg-4)
- ("glew" ,glew)
- ("glu" ,glu)
- ("glx" ,mesa-utils)
- ("gsm" ,gsm)
- ("opengl" ,mesa)
- ("opus" ,opus)
- ("ortp" ,ortp)
- ("pcap" ,libpcap)
- ("portaudio" ,portaudio)
- ("pulseaudio" ,pulseaudio)
- ("spandsp" ,spandsp)
- ("speex" ,speex)
- ("speexdsp" ,speexdsp)
- ("srtp" ,libsrtp)
- ("theora" ,libtheora)
- ("turbojpeg" ,libjpeg-turbo)
- ("v4l" ,v4l-utils)
- ("vpx" ,libvpx)
- ("x11" ,libx11)
- ("xv" ,libxv)
- ("zrtp" ,bzrtp)))
+ (list alsa-lib
+ bcg729
+ bcmatroska2
+ bctoolbox
+ ffmpeg-4
+ glew
+ glu
+ mesa-utils
+ gsm
+ mesa
+ opus
+ ortp
+ libpcap
+ portaudio
+ pulseaudio
+ spandsp
+ speex
+ speexdsp
+ libsrtp
+ libtheora
+ libjpeg-turbo
+ v4l-utils
+ libvpx
+ libx11
+ libxv
+ bzrtp))
(synopsis "Belledonne Communications Streaming Engine")
(description "Mediastreamer2 is a powerful and lightweight streaming engine
for telephony applications. This media processing and streaming toolkit is