aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-04 22:27:32 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-04 22:27:32 +0200
commit2534fc04781aa1bbeb5b3a36cbf9bfa169616a2d (patch)
tree3b2c2b5c19a58cd3a3d8dc5011db48c4310c1b8a /gnu/packages/libreoffice.scm
parent2087023dd48059f273bb7eae9815fb255aa7d0a9 (diff)
downloadguix-2534fc04781aa1bbeb5b3a36cbf9bfa169616a2d.tar.gz
guix-2534fc04781aa1bbeb5b3a36cbf9bfa169616a2d.zip
gnu: Add libwpg.
* gnu/packages/libreoffice.scm (libwpg): New variable.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 32d1792ce2..a832710255 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -28,6 +28,7 @@
#:use-module (gnu packages doxygen)
#:use-module (gnu packages gperf)
#:use-module (gnu packages icu4c)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages xml))
@@ -139,7 +140,6 @@ WordPerfect documents. It is most commonly used to import such documents
into other word processors.")
(license '(mpl2.0 lgpl2.1+)))) ; dually licensed
-
(define-public libe-book
(package
(name "libe-book")
@@ -173,3 +173,29 @@ PalmDoc Ebook, Plucker .pdb, QiOO (mobile format, for java-enabled
cellphones), TCR (simple compressed text format), TealDoc, zTXT,
ZVR (simple compressed text format).")
(license mpl2.0)))
+
+(define-public libwpg
+ (package
+ (name "libwpg")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/libwpg/" name "/" name "-"
+ version ".tar.xz"))
+ (sha256 (base32
+ "097jx8a638fwwfrzf6v29r1yhc34rq9526py7wf0ck2z4fcr2w3g"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("librevenge" ,librevenge)
+ ("libwpd" ,libwpd)
+ ("perl" ,perl)
+ ("zlib" ,zlib)))
+ (home-page "http://libwpg.sourceforge.net/")
+ (synopsis "Library and tools for the WordPerfect Graphics format")
+ (description "The libwpg project provides a library and tools for
+working with graphics in the WPG (WordPerfect Graphics) format.")
+ (license '(mpl2.0 lgpl2.1+)))) ; dually licensed