aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/less.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-08-26 18:35:14 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-26 18:35:14 +0200
commit17dddeeee560527a8f30d37761949d658056cb09 (patch)
tree15b0b19c55787f556eb9b42c28d173bddc5435db /gnu/packages/less.scm
parent331a09654eb7e9f6212b7e8469077fa7393e8b11 (diff)
parent6a9581741e4ee81226aeb2f1c997df76670a6aab (diff)
downloadguix-17dddeeee560527a8f30d37761949d658056cb09.tar.gz
guix-17dddeeee560527a8f30d37761949d658056cb09.zip
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/less.scm')
-rw-r--r--gnu/packages/less.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/less.scm b/gnu/packages/less.scm
index f6ee355b68..7c5107de09 100644
--- a/gnu/packages/less.scm
+++ b/gnu/packages/less.scm
@@ -80,7 +80,17 @@ text editors.")
(invoke "./configure"
(string-append "--prefix=" out)
"--yes")
- #t))))))
+ #t)))
+ (add-before 'install 'patch-tput-and-file
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "lesspipe.sh"
+ (("tput colors")
+ (string-append (assoc-ref inputs "ncurses")
+ "/bin/tput colors"))
+ (("file -")
+ (string-append (assoc-ref inputs "file")
+ "/bin/file -")))
+ #t)))))
(inputs
`(("file" ,file)
("ncurses" ,ncurses))) ; for tput