aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lean.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-07-23 21:43:06 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-07-23 21:43:06 +0200
commitd726b954baaeff876ce9728e00920fa45f529f9a (patch)
tree4b767b7586a1082dd2691bc33c3e45ace044e6e5 /gnu/packages/lean.scm
parent9a74a7db8626bc139307d115f5cec2648f5273ad (diff)
parente165a2492d73d37c8b95d6970d453b9d88911ee6 (diff)
downloadguix-d726b954baaeff876ce9728e00920fa45f529f9a.tar.gz
guix-d726b954baaeff876ce9728e00920fa45f529f9a.zip
Merge branch 'master' into core-updates
Conflicts: gnu/packages/ruby.scm
Diffstat (limited to 'gnu/packages/lean.scm')
-rw-r--r--gnu/packages/lean.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/lean.scm b/gnu/packages/lean.scm
index 235113d475..0cc67da874 100644
--- a/gnu/packages/lean.scm
+++ b/gnu/packages/lean.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
+;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,7 +27,7 @@
(define-public lean
(package
(name "lean")
- (version "3.5.0")
+ (version "3.17.1")
(home-page "https://github.com/leanprover-community/lean")
(source (origin
(method git-fetch)
@@ -35,12 +36,19 @@
(file-name (git-file-name name version))
(sha256
(base32
- "1fdblq8ckrv6wqxfl4ybcs3ybfq7y096c9f5j4j75ymb14r401lr"))))
+ "15yfryg98x9lvy00v1w5kg4hp921mpvlxx1ic3m08k1ls6p1gkj4"))))
(build-system cmake-build-system)
(inputs
`(("gmp" ,gmp)))
(arguments
`(#:build-type "Release" ; default upstream build type
+ ;; XXX: Test phases currently fail on 32-bit sytems.
+ ;; Tests for those architectures have been temporarily
+ ;; disabled, pending further investigation.
+ #:tests? ,(let ((arch (or (%current-target-system)
+ (%current-system))))
+ (not (or (string-prefix? "i686" arch)
+ (string-prefix? "armhf" arch))))
#:phases
(modify-phases %standard-phases
(add-after 'patch-source-shebangs 'patch-tests-shebangs