aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/language.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-16 23:07:55 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-17 13:03:49 -0500
commitfc436dbaea68ef727ec7bdba80e4bae4fcfe27b5 (patch)
treedc34d706b2c1172aa8466041ef99ff0f3cbb5cbf /gnu/packages/language.scm
parent8ac8f1e0c9b9a4fa5db141ac8b9ae847fe2a3508 (diff)
downloadguix-fc436dbaea68ef727ec7bdba80e4bae4fcfe27b5.tar.gz
guix-fc436dbaea68ef727ec7bdba80e4bae4fcfe27b5.zip
gnu: Add Lingua-EN-Words2Nums.
* gnu/packages/language.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/language.scm')
-rw-r--r--gnu/packages/language.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
new file mode 100644
index 0000000000..fbf27f0e71
--- /dev/null
+++ b/gnu/packages/language.scm
@@ -0,0 +1,43 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages language)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages perl)
+ #:use-module (guix packages)
+ #:use-module (guix build-system perl)
+ #:use-module (guix download))
+
+(define-public perl-lingua-en-words2nums
+ (package
+ (name "perl-lingua-en-words2nums")
+ (version "0.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/J/JO/JOEY/"
+ "Lingua-EN-Words2Nums-" version ".tar.gz"))
+ (sha256
+ (base32
+ "118xx8qr1zbx30psv7ic55w65h15mc1vz6zicshfm96jgiwmcrb8"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Lingua-EN-Words2Nums")
+ (synopsis "Convert English text to numbers")
+ (description "This module converts English text into numbers. It supports
+both ordinal and cardinal numbers, negative numbers, and very large numbers.")
+ (license (package-license perl))))