aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-07 00:23:15 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:20 +0800
commitbb52a559a2b79766b9270e647a241b0ddc9dc5a1 (patch)
tree609310399913be151f02eed3ef5c60c925ee0c14 /gnu/packages/kde.scm
parent6eee6b9e9ff575df0251d1801fc620bcf5be0565 (diff)
downloadguix-bb52a559a2b79766b9270e647a241b0ddc9dc5a1.tar.gz
guix-bb52a559a2b79766b9270e647a241b0ddc9dc5a1.zip
gnu: kdenlive: Enable qt6.
* gnu/packages/kde.scm (kdenlive): Enable qt6. [inputs]: Remove qtbase-5, qtdeclarative-5, qtgraphicaleffects, qtmultimedia-5, qtnetworkauth-5, qtquickcontrols-5, qtquickcontrols2-5, qtscript, and qtsvg-5; add ktextwidgets, qtbase, qtdeclarative, qtmultimedia, qtnetworkauth, and qtsvg. [native-inputs]: Remove qttools-5; add qttools. [arguments]: Set #:qtbase to qtbase. <#:phases>: Adjust wrap-executable phase. Change-Id: I7ca594d25c46b94c676b86e98e3e6c0dc11ea6ff
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index f3604eb597..0170f41f8d 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -344,6 +344,7 @@ annotating features.")
;; 1/3 tests failed and 1/327 assertions failed. It seems
;; that individual tests can't be skipped.
(list
+ #:qtbase qtbase
#:configure-flags #~(list "-DBUILD_TESTING=off")
#:tests? #f
#:phases
@@ -362,11 +363,11 @@ annotating features.")
`("LADSPA_PATH" ":" =
(,(string-append ladspa "/lib/ladspa")))
`("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
- (,(string-append qtbase "/lib/qt5/plugins/platforms")))
+ (,(string-append qtbase "/lib/qt6/plugins/platforms")))
`("MLT_PREFIX" ":" =
(,#$(this-package-input "mlt"))))))))))
(native-inputs
- (list extra-cmake-modules kdoctools pkg-config qttools-5))
+ (list extra-cmake-modules kdoctools pkg-config qttools))
(inputs
(list bash-minimal
breeze ; make dark them available easily
@@ -387,18 +388,15 @@ annotating features.")
knotifyconfig
kparts
kplotting
+ ktextwidgets
ladspa
mlt
purpose
- qtbase-5
- qtdeclarative-5
- qtgraphicaleffects
- qtmultimedia-5
- qtnetworkauth-5
- qtquickcontrols-5
- qtquickcontrols2-5
- qtscript
- qtsvg-5
+ qtbase
+ qtdeclarative
+ qtmultimedia
+ qtnetworkauth
+ qtsvg
shared-mime-info))
(home-page "https://kdenlive.org")
(synopsis "Non-linear video editor")