aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-08 11:55:17 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:24 +0800
commita789e41c9cbf9f8759ec4a0174a4196c4f5cac9b (patch)
tree4b41f211c4a7d3411c0cefa1176f686196b3e420 /gnu/packages/kde.scm
parent016bda90f34fe1e1c13695f9c1798ca639c5ff75 (diff)
downloadguix-a789e41c9cbf9f8759ec4a0174a4196c4f5cac9b.tar.gz
guix-a789e41c9cbf9f8759ec4a0174a4196c4f5cac9b.zip
gnu: akregator: Update to 24.05.2.
* gnu/packages/kde.scm (akregator): Update to 24.05.2. [inputs]: Remove gpgme, grantlee, qgpgme, qtbase-5, qtdeclarative-5, qtwebchannel-5, and qtwebengine-5; add gpgme-1.23, kstatusnotifieritem, ktextwidgets, qgpgme-qt6-1.23, qtdeclarative, qtwebchannel, and qtwebengine. [arguments]: Set #:qtbase to qtbase; Use Gexps; Adjust wrap-qt-process-path phase. Change-Id: I5897f2ca0fba2f9df8b36d800cad2d95dfe61c79
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm41
1 files changed, 21 insertions, 20 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 7280d1125b..a0e20dc110 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -191,27 +191,28 @@ This package contains GUI widgets for baloo.")
(define-public akregator
(package
(name "akregator")
- (version "23.04.3")
+ (version "24.05.2")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/akregator-" version ".tar.xz"))
(sha256
- (base32 "0g916453zip8i5g61pf8ib68fiqfbmr1i1lhbnwmsv1cryx035w9"))))
+ (base32 "07flc3617px9w1c729p0lsixf1g0h297hkbip259ykkbwxizn71q"))))
(build-system qt-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-qt-process-path
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin/akregator"))
- (qt-process-path
- (search-input-file
- inputs "/lib/qt5/libexec/QtWebEngineProcess")))
- (wrap-program bin
- `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))))))))
+ (list #:qtbase qtbase
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-qt-process-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/akregator"))
+ (qt-process-path
+ (search-input-file
+ inputs "/lib/qt6/libexec/QtWebEngineProcess")))
+ (wrap-program bin
+ `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))))))))
(native-inputs
(list extra-cmake-modules kdoctools))
(inputs
@@ -220,8 +221,7 @@ This package contains GUI widgets for baloo.")
akonadi-mime
boost
breeze-icons
- gpgme
- grantlee
+ gpgme-1.23
grantleetheme
kcmutils
kcontacts
@@ -236,16 +236,17 @@ This package contains GUI widgets for baloo.")
kpimcommon
kpimtextedit
kquickcharts
+ kstatusnotifieritem
ktextaddons
ktexteditor
+ ktextwidgets
kuserfeedback
libkdepim
libkleo
- qgpgme
- qtbase-5
- qtdeclarative-5
- qtwebchannel-5
- qtwebengine-5
+ qgpgme-qt6-1.23
+ qtdeclarative
+ qtwebchannel
+ qtwebengine
syndication))
(home-page "https://apps.kde.org/en/akregator")
(synopsis "KDE Feed Reader")