aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 18:29:54 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:15 +0800
commit949e291fcc50ca6c584fd68d434c52849331a5bb (patch)
treea4b0462b6b62f1bb9df41fccb20c5601487bf89b /gnu/packages/kde.scm
parent437f515d5e30d00e80d3830f876706b6faabfeab (diff)
downloadguix-949e291fcc50ca6c584fd68d434c52849331a5bb.tar.gz
guix-949e291fcc50ca6c584fd68d434c52849331a5bb.zip
gnu: grantleetheme: Update to 24.05.2.
* gnu/packages/kde.scm (grantleetheme): Update to 24.05.2. [arguments]: Set #:qtbase to qtbase. [inputs]: Remove grantlee, qtbase-5; add kxmlgui. [propagated-inputs]: Add ktexttemplate. Change-Id: I8778c183a57706de36b82f7a3193c07668839d39
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 49fc722e79..275901444c 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -161,25 +161,27 @@ This package contains GUI widgets for baloo.")
(define-public grantleetheme
(package
(name "grantleetheme")
- (version "23.04.3")
+ (version "24.05.2")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/grantleetheme-" version ".tar.xz"))
(sha256
- (base32 "01kkj3y6xhc792jaxnkglkwvlqx9ckn5yhlfrpqff5hlf5x9vn4w"))))
+ (base32 "0fsp9698wh2h53qglfg6576m309yb91s5ix4sdzckyilh31y1j2y"))))
(build-system qt-build-system)
- (arguments `(#:tests? #f)) ; unexpected error in the test suite.
+ (arguments (list
+ #:qtbase qtbase
+ #:tests? #f)) ; unexpected error in the test suite.
(native-inputs
(list extra-cmake-modules libxml2)) ;; xmllint required for tests
(inputs
- (list grantlee
- kguiaddons
+ (list kguiaddons
ki18n
kiconthemes
knewstuff
- qtbase-5))
+ kxmlgui))
+ (propagated-inputs (list ktexttemplate))
(home-page "https://invent.kde.org/pim/grantleetheme")
(synopsis "Library providing Grantlee theme support")
(description "This library provides Grantlee theme support.")