aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-12 14:33:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-12 14:36:44 +0300
commit322917aeb8e672c21378fd371a5cff4a9f0c2520 (patch)
tree70229faa39f14caa09b769153453c3898f64f7fc /gnu/packages/kde.scm
parent407f017663c97ebfe48e3cb304bf97bf2557f83f (diff)
parente1baf802ccd8af4f7b416b0987db706f2dbfc42f (diff)
downloadguix-322917aeb8e672c21378fd371a5cff4a9f0c2520.tar.gz
guix-322917aeb8e672c21378fd371a5cff4a9f0c2520.zip
Merge remote-tracking branch 'origin/master' into staging
Conflicts: gnu/packages/gnuzilla.scm gnu/packages/graphics.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/kde-frameworks.scm gnu/packages/video.scm
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index e83470bc53..1d4321237a 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -751,7 +751,7 @@ different notification systems.")
qtquickcontrols-5
qtquickcontrols2-5
qtx11extras
- qtwayland
+ qtwayland-5
wayland))
(home-page "https://community.kde.org/KDEConnect")
(synopsis "Enable your devices to communicate with each other")
@@ -902,6 +902,33 @@ charts.")
partitions, floppy and CD drives, etc.) along with information on their
capacity, free space, type and mount point. It also allows you to mount and
unmount drives and view them in a file manager.")
+(license license:gpl2+)))
+
+(define-public ktimer
+ (package
+ (name "ktimer")
+ (version "20.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/ktimer-" version ".tar.xz"))
+ (sha256
+ (base32
+ "12fz5v5ky03h18jl75fnq1zagjq8qzi1s1q7phjz5d1rbhwc57ls"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules
+ kdoctools))
+ (inputs
+ (list kdbusaddons
+ ki18n
+ kio
+ knotifications))
+ (home-page "https://kde.org/applications/utilities/ktimer")
+ (synopsis "Countdown Launcher")
+ (description "KTimer is a little tool to execute programs after some time.
+It allows you to enter several tasks and to set a timer for each of them. The
+timers for each task can be started, stopped, changed, or looped.")
(license license:gpl2+)))
(define-public kcachegrind