aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 16:47:57 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:12 +0800
commitf799d4016395486bdb3f539c7564a5f066cda009 (patch)
tree88b4c95594bb546289fd72a575c295cc1051a251 /gnu/packages/kde-plasma.scm
parent0aacc7211c9ab863971b3cfb8ae215d2bed1ec87 (diff)
downloadguix-f799d4016395486bdb3f539c7564a5f066cda009.tar.gz
guix-f799d4016395486bdb3f539c7564a5f066cda009.zip
gnu: plasma: Update to 6.1.2.
* gnu/packages/kde-plasma.scm (plasma): Update to 6.1.2. [propagated-inputs]: Remove kgamma, khotkeys, kinit, kdesu, krunner, and kwayland-integration; add plasma5support, qt5compat, kiconthemes, ksvg, ocean-sound-theme, qtdeclarative, qtsvg, qtbase, layer-shell-qt, krdp, plasma-workspace-wallpapers, qqc2-breeze-style, and kglobalacceld. Change-Id: I66ec11d31004c69a03f45f4ad0bd9c3363bd8e74
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 8c70eee1a4..20b073706f 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1619,7 +1619,7 @@ on top of Baloo.")
(define-public plasma
(package
(name "plasma")
- (version "5.27.7")
+ (version "6.1.2")
(source #f)
(build-system trivial-build-system)
(arguments
@@ -1627,36 +1627,38 @@ on top of Baloo.")
(mkdir #$output))))
;; TODO: cleanup, check what is no need
(propagated-inputs (list kdeclarative ;; require by sddm breeze theme
+ plasma5support ;; require by sddm breeze theme
+ qt5compat ;; require by sddm breeze theme
+ kiconthemes ;; require by sddm breeze theme
+ ksvg ;; require by sddm breeze theme
qqc2-desktop-style ; qtquickcontrols2 theme
+ ocean-sound-theme
+ qtdeclarative
+ qtsvg ;; for svg support
+ qtbase ;; why?
baloo
breeze-icons ; default mouse icon
breeze
breeze-gtk
+ layer-shell-qt
drkonqi
kactivitymanagerd ; require this run dbus
kde-cli-tools
kdecoration
kdeplasma-addons
- kgamma
- khotkeys
ktexteditor
-
kscreen
libkscreen
-
+ krdp
ksystemstats
kwallet-pam
kwin
- kinit
-
+ plasma-workspace-wallpapers
libksysguard
milou
- ;; oxygen
oxygen-sounds
-
+ qqc2-breeze-style
kde-gtk-config
- kdesu
- krunner
kinfocenter
kscreenlocker
ksshaskpass
@@ -1682,16 +1684,14 @@ on top of Baloo.")
(resolve-interface
'(gnu packages kde-systemtools))
'spectacle)
-
- kwayland-integration
plasma-firewall
plasma-integration
plasma-nm
plasma-pa
plasma-systemmonitor
;; plasma-thunderbolt ;; waiting for bolt
-
kglobalaccel
+ kglobalacceld
plasma-vault
plasma-workspace
powerdevil))