aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-15 16:13:27 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-02 22:27:42 +0800
commitcd8e07e7cbb744f91acb9746f433288c646b3a4c (patch)
tree46e4b7fc2f4e190f115947e3069b955bc4dd8818 /gnu/packages/kde-plasma.scm
parent70acb47df11f44ed933d0a65189f8acda7c52200 (diff)
downloadguix-cd8e07e7cbb744f91acb9746f433288c646b3a4c.tar.gz
guix-cd8e07e7cbb744f91acb9746f433288c646b3a4c.zip
gnu: bluedevil: Update to 5.27.6.
* gnu/packages/kde-plasma.scm (bluedevil): Update to 5.27.6. [native-inputs]: Add tzdata-for-tests. [arguments]: Set "TZDIR" in the check phase. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 600b0f4a04..ba7b91b001 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -76,6 +76,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages base)
#:use-module (gnu packages web))
(define-public bluedevil
@@ -424,23 +425,27 @@ KDE Frameworks 5 to better interact with the system.")
(define-public kdeplasma-addons
(package
(name "kdeplasma-addons")
- (version "5.25.5")
+ (version "5.27.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/plasma/" version
"/" name "-" version ".tar.xz"))
(sha256
(base32
- "1a5cq0jz69hlcr22wxi2p5mzxv5xcp88220irxmq0dhpk85kywlx"))))
+ "11zhpb4gcz4yy2v0j8mfzihi9rj35f83i8bi7iirix0vm100sfrl"))))
(build-system qt-build-system)
(arguments
(list #:phases #~(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+
(when tests?
+ (setenv "TZDIR"
+ (search-input-directory
+ inputs "share/zoneinfo"))
(invoke "ctest" "-E"
- "(converterrunnertest|spellcheckrunnertest)")))))))
- (native-inputs (list extra-cmake-modules))
+ "(converterrunnertest)")))))))
+ (native-inputs (list extra-cmake-modules tzdata-for-tests))
(inputs (list karchive
kconfig
kcoreaddons
@@ -457,8 +462,8 @@ KDE Frameworks 5 to better interact with the system.")
plasma-framework
purpose
sonnet
+ ;; qtwebengine-5 ; Optional for online dictionary
qtdeclarative-5))
- ;qtwebengine-5)) ;; Optional for online dictionary
(synopsis "Add-ons to improve your Plasma experience")
(description
"This package provides multiple addons for the Plasma Desktop.")