aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 13:23:43 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:08 +0800
commit89f3165b6a9ad1c5fe1b028c5630449b12d4f5ac (patch)
treeb4822e8c0b63b7e47651345978f5e46ae863e2b8 /gnu/packages/kde-plasma.scm
parentb606d1d29103aeb27f7394c384091483a1df8c25 (diff)
downloadguix-89f3165b6a9ad1c5fe1b028c5630449b12d4f5ac.tar.gz
guix-89f3165b6a9ad1c5fe1b028c5630449b12d4f5ac.zip
gnu: kscreenlocker: Update to 6.1.2.
* gnu/packages/kde-plasma.scm (kscreenlocker): Update to 6.1.2. [arguments]: Set #:qtbase to qtbase. [inputs]: Remove kdeclarative, ktextwidgets, libseccomp, libxcursor, qtbase-5, qtdeclarative-5, and qtx11extras; add ksvg, libplasma, libxkbcommon, and qtdeclarative. [native-inputs]: Add wayland. Change-Id: I6c75c378a3aa671db0e20785333c9a1f4207eae2
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index cdc27ad49d..5ffa1cbbe8 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -980,17 +980,18 @@ an elegant and intuitive experience for your tasks and plasmoids.")
(define-public kscreenlocker
(package
(name "kscreenlocker")
- (version "5.27.7")
+ (version "6.1.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/plasma/" version
"/kscreenlocker-" version ".tar.xz"))
(sha256
(base32
- "11y3ksd29p8hdn8chaf8vscnc7fbh8xkjdsbakrb056p1r8kn0f2"))))
+ "1nk23jbi4n22hhffriqxx2845b4kfn676y910dv85c2b1mkipcxs"))))
(build-system qt-build-system)
(arguments
(list #:tests? #f ;TODO: make tests pass
+ #:qtbase qtbase
#:phases #~(modify-phases %standard-phases
(add-before 'check 'check-setup
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -1005,31 +1006,30 @@ an elegant and intuitive experience for your tasks and plasmoids.")
(setenv "CTEST_OUTPUT_ON_FAILURE" "1")
(invoke "dbus-launch" "ctest"))))))))
(native-inputs (list extra-cmake-modules pkg-config
+ ;; for WaylandScanner
+ wayland
;; For tests.
dbus xorg-server-for-tests))
(inputs (list kcmutils
kconfig
kcrash
- kdeclarative
kglobalaccel
ki18n
kio
kidletime
knotifications
- ktextwidgets
kwayland
kwindowsystem
kxmlgui
+ ksvg
layer-shell-qt
libkscreen
- libseccomp ;for sandboxing the look'n'feel package
- libxcursor ;missing in CMakeList.txt
+ libplasma
libxi ;XInput, required for grabbing XInput2 devices
linux-pam
+ libxkbcommon
elogind ;optional loginctl support
- qtbase-5
- qtdeclarative-5
- qtx11extras
+ qtdeclarative
solid
wayland
xcb-util-keysyms))