aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-05-02 23:12:19 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:07 +0800
commit7ce98fe4d93d64b99763227e253e86fa537b7f7e (patch)
tree8555b65dbbfac27dffe1470f5b8a2e026bf47fb4 /gnu/packages/kde-plasma.scm
parent69149f1fb63bde174fe233475f46dcb6e40cb505 (diff)
downloadguix-7ce98fe4d93d64b99763227e253e86fa537b7f7e.tar.gz
guix-7ce98fe4d93d64b99763227e253e86fa537b7f7e.zip
gnu: libksysguard: Update to 6.1.2.
* gnu/packages/kde-plasma.scm (libksysguard): Update to 6.1.2. [source]: Remvoe patches. [inputs]: Remove plasma-framework, qtbase-5, qtdeclarative-5, qtscript, qtwebchannel-5, qtwebengine-5, and qtx11extras; add libplasma, qtdeclarative, qtwebchannel, and qtwebengine. [native-inputs]: Remove qttools-5; add qttools. [arguments]: Set #:qtbase to qtbase. * gnu/packages/patches/libksysguard-qdiriterator-follow-symlinks.patch: Remove it. * gnu/local.mk (dist_patch_DATA): Unregister it. Change-Id: Ic5b88315da7682dcd47ec19894b8ed88b87d6688
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index b617b95eb8..63d7dd99c3 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1090,17 +1090,16 @@ basic needs and easy to configure for those who want special setups.")
(define-public libksysguard
(package
(name "libksysguard")
- (version "5.27.7")
+ (version "6.1.2")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/plasma/" version
"/libksysguard-" version ".tar.xz"))
- (patches (search-patches "libksysguard-qdiriterator-follow-symlinks.patch"))
(sha256
- (base32 "066bjar4105bfyry6ni7nnikz66bqzy5nvssz6vm4np3aa996ak8"))))
+ (base32 "1l1fy5i9yxh7fnxfyfsk0hnyd1vfzac336kcfwklkqa7l796hpc0"))))
(native-inputs
- (list bash-minimal extra-cmake-modules pkg-config qttools-5))
+ (list bash-minimal extra-cmake-modules pkg-config qttools))
(inputs
(list kauth
kcompletion
@@ -1120,22 +1119,21 @@ basic needs and easy to configure for those who want special setups.")
libcap
libpcap
`(,lm-sensors "lib")
- plasma-framework
- qtbase-5
- qtdeclarative-5
- qtscript
- qtwebchannel-5
- qtwebengine-5
- qtx11extras
+ libplasma
+ qtdeclarative
+ qtwebchannel
+ qtwebengine
zlib))
(build-system qt-build-system)
(arguments
- (list #:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'fix-test
- (lambda* _
- (substitute* "autotests/processtest.cpp"
- (("/bin/sh")
- (which "bash"))))))))
+ (list
+ #:qtbase qtbase
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-test
+ (lambda* _
+ (substitute* "autotests/processtest.cpp"
+ (("/bin/sh")
+ (which "bash"))))))))
(home-page "https://userbase.kde.org/KSysGuard")
(synopsis "Network enabled task and system monitoring")
(description "KSysGuard can obtain information on system load and