aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-02 19:32:20 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-03 17:38:12 +0800
commit67def63b48fc8f46a38f448993865c1bdc9b7668 (patch)
treecae035eaac6efacdc1bddda57068015cdc2e4a4f /gnu/packages/kde-plasma.scm
parenta7c632b2b0157f21fc4363ae689ade72b4173fc2 (diff)
downloadguix-67def63b48fc8f46a38f448993865c1bdc9b7668.tar.gz
guix-67def63b48fc8f46a38f448993865c1bdc9b7668.zip
gnu: Remove kwayland-server.
KWaylandServer has been merged with KWin. * gnu/packages/kde-plasma.scm (kwayland-server): Remove package. (kwin)[inputs]: Remove kwayland-server.
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm50
1 files changed, 0 insertions, 50 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 3286f3d384..fd882aa238 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1116,55 +1116,6 @@ you login.")
(home-page "https://invent.kde.org/plasma/kwallet-pam")
(license (list license:lgpl2.1+))))
-(define-public kwayland-server
- (package
- (name "kwayland-server")
- (version "5.24.7")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://kde/stable/plasma/" version
- "/" name "-" version ".tar.xz"))
- (sha256
- (base32
- "0kgqldqaq0dxfh0nh705sq9ynndi996rwjzxhhdrvr5ag40zm480"))))
- (build-system qt-build-system)
- (native-inputs
- (list extra-cmake-modules pkg-config))
- (inputs
- (list plasma-wayland-protocols
- qtbase-5
- qtwayland-5
- kwayland
- wayland
- wayland-protocols))
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-install-path
- (lambda _
- ;; Fixes errors including nonexistant /include/KF5
- (substitute* "src/server/CMakeLists.txt"
- (("KF5_INSTALL") "KDE_INSTALL"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "HOME" (getcwd))
- (setenv "XDG_RUNTIME_DIR" (getcwd))
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (invoke "ctest" "-E"
- ;; This test fails inconsistently.
- "kwayland-testDragAndDrop")))))))
- (home-page "https://api.kde.org/kwayland-server/html/index.html")
- (synopsis "KDE wayland server component")
- (description
- "KWayland is a Qt-style API to interact with the wayland-client and
-wayland-server API.")
- ;; Most files are LGPL2.1 or LGPL3.0 only, at the users option.
- (license (list license:lgpl2.1 license:lgpl3
- ;; src/server/drm_fourcc.h carries the MIT license.
- license:expat))))
-
(define-public kwayland-integration
(package
(name "kwayland-integration")
@@ -1331,7 +1282,6 @@ KDE Frameworks components.")
kscreenlocker
ktextwidgets
kwayland
- kwayland-server
kwindowsystem
kxmlgui
libqaccessibilityclient